Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

Unable to create DepthCameraSensor when launching in remote computer

Hi, I am launching my simulation on a remote computer and setting my ROS_MASTER_URI to it. To avoid walking to the remote computer (which is at the other side of the room) I connect remotely (ssh) to it an launch the simulation there. Since I do not need the rendering, just the simulation, I use gzserver.

However, when I launch the world with gzserver remotely I get the following error:

gzserver my_world_with_a_kinect.world

[Msg] Waiting for master.
[Msg] Connected to gazebo master @ http://127.0.0.1:11345
[Msg] Publicized address: 192.168.100.106
[Err] [RenderEngine.cc:680] Can't open display: 
[Wrn] [RenderEngine.cc:92] Unable to create X window. Rendering will be disabled 
[Err] [DepthCameraSensor.cc:78] Unable to create DepthCameraSensor. Rendering is disabled.

Testing with rviz, I see nothing. The depth camera topics are not even created.

However, if I move to the remote computer and execute the same command everything works OK.

I know that been a remote connection, you don't have the Xs unless you connect with ssh -X <ip>. My computer is a Mac and does not have the Xs. Some people suggested me to install Xs but I cannot (for several reasons).

Additionally, I am running other remote simulations and evn if I get the 'Can't open display' error message, everything works fine.

The question is: how can I make the kinect work properly in such a remote environment?

click to hide/show revision 2
improved style

Unable to create DepthCameraSensor when launching in remote computer

Hi, I am launching my simulation on a remote computer and setting my ROS_MASTER_URI to it. To avoid walking to the remote computer (which is at the other side of the room) I connect remotely (ssh) to it an launch the simulation there. Since I do not need the rendering, just the simulation, I use gzserver.

However, when I launch the world with gzserver remotely I get the following error:

gzserver my_world_with_a_kinect.world

[Msg] Waiting for master.
[Msg] Connected to gazebo master @ http://127.0.0.1:11345
[Msg] Publicized address: 192.168.100.106
[Err] [RenderEngine.cc:680] Can't open display: 
[Wrn] [RenderEngine.cc:92] Unable to create X window. Rendering will be disabled 
[Err] [DepthCameraSensor.cc:78] Unable to create DepthCameraSensor. Rendering is disabled.

Testing with rviz, I see nothing. The depth camera topics are not even created.

However, if I move to the remote computer and execute the same command everything works OK.

I know that been a remote connection, you don't have the Xs unless you connect with ssh -X <ip>. My computer is a Mac and does not have the Xs. Some people suggested me to install Xs but I cannot (for several reasons).

Additionally, I am running other remote simulations and evn if I get the 'Can't open display' error message, everything works fine.

The question is: how can I make the kinect work properly in such a remote environment?