Gazebo | Ignition | Community
Ask Your Question

Vale's profile - activity

2015-05-27 06:02:42 -0500 received badge  Famous Question (source)
2015-05-21 06:05:25 -0500 received badge  Famous Question (source)
2015-05-21 06:05:25 -0500 received badge  Notable Question (source)
2015-05-21 06:05:25 -0500 received badge  Popular Question (source)
2015-02-17 03:16:46 -0500 commented question Multiple models with a Gazebo plugin

I have fixed this problem in this way:

2015-02-15 17:05:55 -0500 received badge  Notable Question (source)
2015-02-09 18:38:56 -0500 received badge  Popular Question (source)
2015-02-08 07:59:11 -0500 commented question Multiple models with a Gazebo plugin

Yes, stiffness and position are two different values. And for cubebot 1 I have stiffness1, position1 (topics for cubebot1), and stiffness2 , position2 for cubebot 2. But this method doesn't work. Do you have any ideas?

2015-02-08 07:11:08 -0500 commented question Multiple models with a Gazebo plugin

I have attached the plugin I am using. I receive messages on different ROS topics. If you have questions, just ask. Thank you.

2015-02-08 07:09:32 -0500 received badge  Editor (source)
2015-02-08 06:32:20 -0500 commented question Multiple models with a Gazebo plugin

Even if I use different topics, only one topic works, but both cubes move. And I don't know why.

2015-02-08 04:26:06 -0500 asked a question Multiple models with a Gazebo plugin

Hello everyone,

I have a problem and I don't know how to fix it. I have an sdf file which includes multiple models within it, such as:

<include>
  <uri>model://CubeBot</uri>
  <name>cubebot_1</name>
  <pose>0 0.117 0 -1.57 -1.57 0</pose>    
</include>

<include>
  <uri>model://CubeBot</uri>
  <name>cubebot_2</name>
  <pose>0 0.117 0 -1.57 -1.57 0</pose>    
</include>

and each CubeBot model has a plugin to control it. I control their positions by using a ROS topic which communicates with Gazebo (stand-alone version). I use an array in the plugin in Gazebo to receive different reference positions from ROS, but it doesn't work. In fact when I command a CubeBot to move, (and only it), then even the other CubeBot moves, and I don't want it. Is it possible to fix this problem? I use Gazebo 2.2 and ROS indigo. Thanks a lot.

PS : plugin has been attached C:\fakepath\plugin_cubebot.cc

And these are sdf models: cubebot model C:\fakepath\model.sdf and manipulator model C:\fakepath\model.sdf

2015-02-08 04:24:45 -0500 asked a question Multiple model with Gazebo plugin

Hello everyone,

I have a problem and I don't know how to fix it. I have an sdf file which includes multiple models within it, such as:

<model name="manipulator" &gt;="" <include=""> <uri>model://CubeBot</uri> <name>cubebot_1</name> <pose>0 0.117 0 -1.57 -1.57 0</pose>
</include>

<include>
  <uri>model://CubeBot</uri>
  <name>cubebot_2</name>
  <pose>0 0.117 0 -1.57 -1.57 0</pose>    
</include>

</model>

and each CubeBot model has a plugin to control it. I control their positions by using a ROS topic which communicates with Gazebo (stand-alone version). I use an array in the plugin in Gazebo to receive different reference positions from ROS, but it doesn't work. In fact when I command a CubeBot to move, (and only it), then even the other CubeBot moves, and I don't want it. Is it possible to fix this problem? I use Gazebo 2.2 and ROS indigo. Thanks a lot.

Vale