Gazebo | Ignition | Community
Ask Your Question

soulslicer's profile - activity

2017-09-10 19:46:48 -0500 received badge  Famous Question (source)
2017-09-10 19:46:48 -0500 received badge  Notable Question (source)
2017-09-10 19:46:48 -0500 received badge  Popular Question (source)
2017-04-19 15:31:51 -0500 received badge  Famous Question (source)
2017-04-19 15:31:51 -0500 received badge  Notable Question (source)
2016-11-10 14:20:06 -0500 received badge  Popular Question (source)
2016-11-01 10:33:02 -0500 commented question Gazebo Block Laser - Avoid Collision with floor

How do I do that? I need it to be visible in my cameras though

2016-10-30 19:48:13 -0500 asked a question Gazebo Block Laser - Avoid Collision with floor

Is there a way to avoid collision with the floor plane?

2016-10-30 19:48:07 -0500 asked a question Gazebo - Parent to child relative pose of a fixed joint keeps changinge

I have the following code

        math::Pose lidarPose = this->model->GetChildLink("LidarLink")->GetRelativePose();

My model is defined as such

<joint name='LidarJoint' type='fixed'>
  <parent>BoatLink</parent>
  <child>LidarLink</child>
  <pose frame=''>0 0 0 0 -0 0</pose>
  <physics>
    <ode>
      <limit>
        <cfm>0</cfm>
        <erp>0.2</erp>
      </limit>
      <suspension>
        <cfm>0</cfm>
        <erp>0.2</erp>
      </suspension>
    </ode>
  </physics>
</joint>

<model name='Lidar'>
  <link name='LidarLink'>
    <pose frame=''>0.490483 -0.009608 0.58868 0 0 0</pose>
    <inertial>
      <mass>0.1</mass>
    </inertial>
</model>

<model name='Boat'>
<link name='BoatLink'>
  <pose frame=''>-4e-06 -5e-06 0 0 -0 0</pose>
</model>

But in my code the lidarPose keeps on changing when the robot moves. Btw the model refers to a plugin to the Boat which is BoatLink. It's a fixed joint shouldnt it be the same

2015-03-24 16:47:00 -0500 received badge  Popular Question (source)
2015-03-19 02:38:22 -0500 asked a question Taking forever to clone Gazebo

I am running the hg clone function on the gazebo repository. It seems permanently stuck on adding file changes. Hitting ctrl+t shows this: load: 1.51 cmd: Python 1780 waiting 23.29u 3.31s

I am not sure what is happening?