Gazebo | Ignition | Community
Ask Your Question

AReimann's profile - activity

2015-08-03 10:03:38 -0600 received badge  Notable Question (source)
2015-08-03 10:03:38 -0600 received badge  Popular Question (source)
2015-08-03 10:03:38 -0600 received badge  Famous Question (source)
2015-05-29 01:46:00 -0600 commented answer Simple heavy differential drive Robot with urdf

Same problem in Gazebo 6. Do you have an idea how to solve this? It's a really basic model.

2015-05-14 03:45:12 -0600 commented answer Simple heavy differential drive Robot with urdf

Using Gazebo 5 and your original model, this happens when I move the robot up and let it fall a bit: https://youtu.be/VI2n5NJLfpw Same happens when I try to drive my model.

2015-05-14 03:18:49 -0600 commented answer Very weird behaviour destroys my robot and makes it fly around

Was the script the official urdf -> sdf generator?

2015-05-14 03:17:16 -0600 received badge  Famous Question (source)
2015-05-07 03:32:10 -0600 commented answer Simple heavy differential drive Robot with urdf

After deleting the springstiffness, springreference and useparentmodelframe elements it runs, but the robot wheels weirdly snap together after a few seconds or when it is lifted: http://i.imgur.com/9asksGG.png / video: http://youtu.be/WJle0KUevM That's not dependent on the mass though

2015-05-07 03:22:14 -0600 commented answer Simple heavy differential drive Robot with urdf

Gazebo version 2.2.5 complains about not being able to downgrade to sdf version 1.4 If i simply change the version number it fails to read elements: http://i.imgur.com/YFrkP9c.png

2015-05-03 22:08:01 -0600 received badge  Notable Question (source)
2015-04-29 10:42:58 -0600 received badge  Popular Question (source)
2015-04-21 00:03:04 -0600 asked a question Simple heavy differential drive Robot with urdf

Hey, I have a rather simple differential drive robot model. The problem is that even though the wheels are restricted to moving only around one axis they move weirdly as shown in this video.

The main body has a high weight.

How can I make this whole thing stable? How can I make the wheels fixed to the main body, except rotation?

Here is the xarco:

<?xml version="1.0" ?>
<robot name="gocart_v2_gazebo" xmlns:xacro="http://www.ros.org/wiki/xacro">

  <xacro:property name="base_link"     value="base_link" />
  <xacro:property name="pi"            value="3.1415926535897931" />

  <!-- cannot put these properties within the macro tags -->
  <xacro:property name="gocart_bias"          value="0.400" />
  <xacro:property name="gocart_wheel_radius"  value="0.0751" />
  <xacro:property name="gocart_caster_radius" value="0.0375" />

  <macro name="cylinder_inertia" params="m r h">
    <inertia  ixx="${m*(3*r*r+h*h)/12}" ixy = "0" ixz = "0"
      iyy="${m*(3*r*r+h*h)/12}" iyz = "0"
      izz="${m*r*r/2}"
    />
  </macro>

  <macro name="box_inertia" params="m x y z">
    <inertia  ixx="${m*(y*y+z*z)/12}" ixy = "0" ixz = "0"
      iyy="${m*(x*x+z*z)/12}" iyz = "0"
      izz="${m*(x*x+z*z)/12}"
    />
  </macro>

  <macro name="sphere_inertia" params="m r">
    <inertia  ixx="${2*m*r*r/5}" ixy = "0" ixz = "0"
      iyy="${2*m*r*r/5}" iyz = "0"
      izz="${2*m*r*r/5}"
    />
  </macro>

  <xacro:macro name="wheel" params="name parent length radius off_x off_y off_z type">
    <joint name="${name}" type="${type}">
      <parent link="${parent}"/>
      <child link="${name}_link"/>
      <origin rpy="0 0 0" xyz="${off_x} ${off_y} ${off_z}"/>
      <axis xyz="1 0 0"/>
      <dynamics damping="1.0" friction="1.0" spring_stiffness="1" />
    </joint>

    <link name="${name}_link">
      <visual>
        <geometry>
          <cylinder length="${length}" radius="${radius}"/>
        </geometry>
        <origin rpy="0 ${pi/2} 0" xyz="0 0 0"/>
      </visual>

      <collision>
        <geometry>
          <cylinder length="${length}" radius="${radius}"/>
        </geometry>
        <origin rpy="0 ${pi/2} 0" xyz="0 0 0"/>
      </collision>

      <inertial>
        <mass value="0.1" />
        <origin rpy="0 ${pi/2} 0" xyz="0 0 0"/>
        <cylinder_inertia m="0.1" r="${radius}" h="${length}"/>
      </inertial>
    </link>

    <gazebo reference="${name}">
<!--       <implicitSpringDamper>true</implicitSpringDamper> -->
    </gazebo>

    <gazebo reference="${name}_link">
      <mu1 value="100000.0" />
      <mu2 value="100000.0" />
      <kp value="100000.0" />
      <kd value="0.00001" />
      <maxVel value="1.0" />
      <minDepth value="0.0001" />
    </gazebo>    
  </xacro:macro>

  <xacro:macro name="caster" params="name parent radius off_x off_y off_z type">
    <joint name="${name}" type="${type}">
      <parent link="${parent}"/>
      <child link="${name}_link"/>
      <origin rpy="0 0 ${pi/2}" xyz="${off_x} ${off_y} ${off_z}"/>
      <dynamics damping="1.0" friction="0.0" />
    </joint>

    <link name="${name}_link">
      <visual>
        <origin rpy="0 0 0" xyz="0 0 0"/>
        <geometry>
          <sphere radius="${radius}"/>
        </geometry>
      </visual>

      <collision>
        <origin rpy="0 0 0" xyz="0 0 0"/>
        <geometry>
          <sphere radius="${radius}"/>
        </geometry>
      </collision>

      <inertial>
        <origin xyz="0 0 0" />
        <mass value="0.01" />
        <sphere_inertia m="0.01" r="${radius}"/>
      </inertial>
    </link>

    <gazebo reference="${name}_link">
      <mu1 value="0.0" />
      <mu2 value="0.0" />
      <kp value="1000000.0" />
      <kd value="1.0" />
      <maxVel value ...
(more)
2015-04-07 05:01:46 -0600 received badge  Student (source)
2015-04-05 22:19:43 -0600 received badge  Editor (source)
2015-04-05 22:04:53 -0600 asked a question How to speedup the gazebo ros openni kinect plugin rate

Hello,

I'm simulating a differential drive robot with a Kinect using the gazebo ros openni kinect plugin. The publishing rate I get (with rostopic hz) for the Kinect point cloud is only at around 22 Hz. This is even after slowing down the physics update rate to 100 Hz.

When I slow down the physics update rate further down, e. g. 50 Hz I get the desired 30 Hz. But I think this might lead to some other problems, as it seems rather low.

Is the plugin in general slow and is there a way / parameter to speed it up?

I'm working on a Intel i5 760 @ 2.8 Ghz with a nvidia GTX 650 Ti, not the most powerfull rig but should be okish?

Plugin settings:

<gazebo reference="${link_name}">
    <sensor type="depth" name="${camera_name}">       
        <always_on>1</always_on>
        <update_rate>30.0</update_rate>
        <visualize>true</visualize>             
        <camera>
            <horizontal_fov>1.047</horizontal_fov>  
            <image>
                <width>640</width>
                <height>480</height>
                <format>R8G8B8</format>
            </image>
            <depth_camera>

            </depth_camera>
            <clip>
                <near>0.1</near>
                <far>4</far>
            </clip>
        </camera>
        <plugin name="${camera_name}_controller" filename="libgazebo_ros_openni_kinect.so">
            <alwaysOn>true</alwaysOn>
            <updateRate>30.0</updateRate>
            <cameraName>${robot_topic_prefix}/${camera_name}</cameraName>
            <frameName>${frame_name}</frameName>                   
            <imageTopicName>rgb/image_raw</imageTopicName>
            <depthImageTopicName>depth_capture/image_raw</depthImageTopicName>
            <pointCloudTopicName>depth_capture/points</pointCloudTopicName>
            <cameraInfoTopicName>rgb/camera_info</cameraInfoTopicName>              
            <depthImageCameraInfoTopicName>depth_capture/camera_info</depthImageCameraInfoTopicName>            
            <pointCloudCutoff>0.4</pointCloudCutoff>                
                <hackBaseline>0.07</hackBaseline>
                <distortionK1>0.0</distortionK1>
                <distortionK2>0.0</distortionK2>
                <distortionK3>0.0</distortionK3>
                <distortionT1>0.0</distortionT1>
                <distortionT2>0.0</distortionT2>
            <CxPrime>0.0</CxPrime>
            <Cx>0.0</Cx>
            <Cy>0.0</Cy>
            <focalLength>0.0</focalLength>
            </plugin>
    </sensor>
</gazebo>