Gazebo | Ignition | Community
Ask Your Question

Ahmet Sezgin Duran's profile - activity

2015-05-27 03:48:52 -0500 commented answer How can I reset the simulation properly in Gazebo 4 with ROS Indigo?
2015-05-27 03:47:34 -0500 commented question How can I reset the simulation properly in Gazebo 4 with ROS Indigo?

@nkoenig I checked, they're not spinning.

2015-05-23 09:12:44 -0500 received badge  Famous Question (source)
2015-05-08 00:51:40 -0500 received badge  Notable Question (source)
2015-04-30 05:52:23 -0500 received badge  Popular Question (source)
2015-04-26 06:50:40 -0500 commented question How can I reset the simulation properly in Gazebo 4 with ROS Indigo?

I'm using **`gazebo_plugins`** package's `multi_robot_scenario.launch` file, here take a look: https://github.com/ros-simulation/gazebo_ros_pkgs/blob/d8471f25c0323670be994a4c554903ff06df0bd7/gazebo_plugins/test/multi_robot_scenario/launch/multi_robot_scenario.launch Resetting is done in Gazebo, Edit, Reset World (Ctrl + R shortcut). Movement is simple, just sending Twist commands to related topic, take a look at gist: https://gist.github.com/marjinal1st/17a114c081dbadf3b2f2

2015-04-22 07:26:55 -0500 asked a question How can I reset the simulation properly in Gazebo 4 with ROS Indigo?

Hi,

I'm using ROS Indigo on Ubuntu 14.04. Trying to work with simulation for a project. I need to reset the simulation and start over for quick testing. If I use Gazebo 2.x series with ROS Indigo, resetting simulation works without any problem, I can move robots again.

But when I use Gazebo 4, for example launching with this:

roslaunch gazebo_plugins multi_robot_scenario.launch

After moving robots and resetting the simulation, movement doesn't work. I've to launch the simulation all over again.

Any ideas? (Let me know if I need to provide any information, logs etc.)