Gazebo | Ignition | Community
Ask Your Question

epurdy's profile - activity

2015-10-16 11:12:14 -0500 received badge  Famous Question (source)
2015-07-04 12:13:26 -0500 received badge  Notable Question (source)
2015-07-03 08:06:49 -0500 received badge  Popular Question (source)
2015-07-02 16:43:33 -0500 answered a question Weird collision/gravity behavior

Turns out the trash can had too many polygons, simplifying it in MeshLab fixed the simulation.

2015-07-01 18:45:39 -0500 asked a question Weird collision/gravity behavior

I have a simulation with a coke can and a trash can, and I'm trying to get a robot to put the coke can in the trash can. The problem is that the coke can doesn't always fall into the trash can, sometimes it just kind of sits on top. Sometimes it falls straight in, and sometimes it falls in an incredibly slow way. Sometimes it slowly drops in and then falls the rest of the way at a normal speed.

The coke can is the one that comes with ROS's gazebo_worlds package.

I am using this model for the trashcan: http://www.3dm3.com/modelsbank/model1...

It is wrapped in the following URDF:

<robot name="waste_can_model">
  <link name="waste_can">
    <inertial>
      <mass value="10.0" />
      <!-- center of mass (com) is defined w.r.t. link local coordinate system -->
      <origin xyz="0 0 0.06" />
      <inertia  ixx="3.0" ixy="0.0"  ixz="0.0"  iyy="3.0"  iyz="0.0"  izz="3.0" />
    </inertial>
    <visual>
      <!-- visual origin is defined w.r.t. link local coordinate system -->
      <origin xyz="0 0 -0.18" rpy="0 0 0" />
      <geometry>
        <mesh filename="package://vicarious/objects/3dm-wastcan2.dae" scale="0.03 0.03 0.03" />
      </geometry>
    </visual>
    <collision>
      <!-- collision origin is defined w.r.t. link local coordinate system -->
      <origin xyz="0 0 -0.18" rpy="0 0 0" />
      <geometry>
        <mesh filename="package://vicarious/objects/3dm-wastcan2.dae" scale="0.03 0.03 0.03" />
      </geometry>
    </collision>
  </link>
  <gazebo reference="coke_can">
    <material>Gazebo/Red</material>
    <turnGravityOff>false</turnGravityOff>
    <kp>100000000.0</kp>
    <kd>1000000.0</kd>
  </gazebo>
</robot>

Any idea what's going wrong? Is something wrong with the mesh? Is there a way to validate the mesh?