Gazebo | Ignition | Community
Ask Your Question

dbworth's profile - activity

2013-07-04 03:37:54 -0500 received badge  Famous Question (source)
2013-03-15 14:25:45 -0500 received badge  Popular Question (source)
2013-03-15 14:25:45 -0500 received badge  Notable Question (source)
2013-03-14 08:32:23 -0500 received badge  Famous Question (source)
2013-03-08 10:47:52 -0500 received badge  Popular Question (source)
2013-03-08 10:47:52 -0500 received badge  Notable Question (source)
2013-03-08 10:47:52 -0500 received badge  Famous Question (source)
2013-02-13 17:10:59 -0500 received badge  Popular Question (source)
2013-02-13 17:10:59 -0500 received badge  Notable Question (source)
2013-02-01 13:33:43 -0500 commented answer hg clone = HTTP Error 400: Bad Request

Bitbucket who? The same error can be seen many times on Bitbucket's forums. Thanks for your concern @gerkey Anyway, it looks the masses aren't complaining. Maybe you guys might consider Github too.

2013-02-01 13:29:35 -0500 answered a question hg clone = HTTP Error 400: Bad Request

Yes, I can clone drcsim too

2013-01-18 14:08:50 -0500 answered a question performance: what hardware works best?

Chris,

Just to revive your question... as you found, you're best to stay away from the Quadro series, they are for "workstations" so are lower spec. You can jump on a hardware review site and see how the PC gaming guys compare the latest NVidia cards.

However, CPU cores might have more affect; I think is yet to fully utilize the GPU?

I am curious to know how 8+ cores would perform?

David.

2013-01-17 16:13:58 -0500 commented answer hg clone = HTTP Error 400: Bad Request

Okay, I checked from home, same error. Perhaps you guys can ask BitBucket to fix the repo? a quick Google search shows that error has appeared on other people's repo's. But, I guess most people compiling from source know how to get around this...

2013-01-17 14:02:24 -0500 commented answer Joint Controller Plugin for Gazebo

Awesome, would you like to share this work?

2013-01-17 02:26:55 -0500 commented answer hg clone = HTTP Error 400: Bad Request

It could be a strange network error in our area, but it only seems to be on the gazebo repo.

2013-01-16 15:40:55 -0500 received badge  Editor (source)
2013-01-16 15:37:01 -0500 commented question Gazebo PR2 getting stuck at launch
2013-01-16 15:35:39 -0500 commented question Gazebo PR2 getting stuck at launch

Another libc segfault :-( http://answers.gazebosim.org/question/872/bug-gazebo-segmentation-fault-pr2-spawn-ubuntu/ have attached all BTs you asked for here.

2013-01-16 15:34:15 -0500 commented question Bug: Gazebo segmentation fault - PR2 spawn - Ubuntu Precise Lucid
2013-01-16 15:34:02 -0500 commented question Bug: Gazebo segmentation fault - PR2 spawn - Ubuntu Precise Lucid
2013-01-16 15:33:29 -0500 asked a question Bug: Gazebo segmentation fault - PR2 spawn - Ubuntu Precise Lucid

ROS Fuerte, Gazebo 1.6.16

Hi all,

I've been trying to get Gazebo running on another laptop.
I tried Ubuntu 12.04.1 Precise 64bit,
Ubuntu 10.04.4 Lucid 32bit and 64bit,
various versions of NVidia proprietory drivers from 195.xx and 304.xx series.

In all cases, Gazebo crashes with segmentation fault when getting near the end of completely spawning the PR2.
In this case in seems to be from libc.so.6.
(Other software configurations have segfaulted in a Boost or OpenGL library.)

This bug report focuses on Ubuntu 10.04.4 64bit:

$ glxinfo
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: Quadro FX 3500/PCI/SSE2
OpenGL version string: 2.1.2 NVIDIA 195.36.24
OpenGL shading language version string: 1.20 NVIDIA via Cg compiler

Executing:

roslaunch gazebo_worlds empty_world.launch

with Gazebo set to debug. That loads fine, until I spawn the PR2 using:

roslaunch pr2_gazebo pr2.launch

which causes a segfault in the first console.

See backtrace below. Problem in libc.so.6 after calling Ogre::GLFrameBufferObject::initialise ?


While leaving the crashed programs running

ps -ef | grep gz

produces

/bin/bash /opt/ros/fuerte/stacks/simulator_gazebo/gazebo_worlds/scripts/gdbrun /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/gazebo/bin/gzserver /opt/ros/fuerte/stacks/simulator_gazebo/gazebo_worlds/worlds/empty.world __name:=gazebo __log:=/home/dbworth/.ros/log/02fc2ece-601f-11e2-8f89-00c0ca21e421/gazebo-2.log -s /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/lib/libgazebo_ros_paths_plugin.so -s /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/lib/libgazebo_ros_api_plugin.so
gdb -x /tmp/gdbrun.20686.7.tmp /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/gazebo/bin/gzserver
/opt/ros/fuerte/stacks/simulator_gazebo/gazebo/gazebo/bin/gzclient -g /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/lib/libgazebo_ros_paths_plugin.so
/opt/ros/fuerte/stacks/simulator_gazebo/gazebo/gazebo/bin/gzserver /opt/ros/fuerte/stacks/simulator_gazebo/gazebo_worlds/worlds/empty.world __name:=gazebo __log:=/home/dbworth/.ros/log/02fc2ece-601f-11e2-8f89-00c0ca21e421/gazebo-2.log -s /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/lib/libgazebo_ros_paths_plugin.so -s /opt/ros/fuerte/stacks/simulator_gazebo/gazebo/lib/libgazebo_ros_api_plugin.so

Also see below for output of:

thread apply all bt


I was going to try to build the normal and HG versions from source, but

 hg clone https://bitbucket.org/osrf/gazebo gazebo

gives

requesting all changes
abort: HTTP Error 400: Bad Request


Any help would be most appreciated.

Cheers,
David.


image description


Backtrace:

terminate called after throwing an instance of 'Ogre::InvalidParametersException'
  what():  OGRE EXCEPTION(2:InvalidParametersException): All framebuffer formats with this texture internal format unsupported in GLFrameBufferObject::initialise at /tmp/buildd/ros-fuerte-visualization-common-1.8.4/debian/ros-fuerte-visualization-common/opt/ros/fuerte/stacks/visualization_common/ogre/build/ogre_src_v1-7-3/RenderSystems/GL/src/OgreGLFrameBufferObject.cpp (line 276)

Program received signal SIGABRT, Aborted.
0x00007ffff11e3a75 in raise () from /lib/libc.so.6
(gdb) bt
#0  0x00007ffff11e3a75 in raise () from /lib/libc.so.6
#1  0x00007ffff11e75c0 in abort () from /lib/libc.so.6
#2  0x00007ffff1a998c5 in __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/libstdc++.so.6
#3  0x00007ffff1a97cf6 in ?? () from /usr/lib/libstdc++.so.6
#4  0x00007ffff1a97d23 in std::terminate() () from /usr/lib/libstdc++.so.6
#5  0x00007ffff1a97e1e in __cxa_throw () from /usr ...
(more)
2013-01-16 07:10:30 -0500 asked a question hg clone = HTTP Error 400: Bad Request
$ hg clone https://bitbucket.org/osrf/gazebo gazebo

requesting all changes abort: HTTP
Error 400: Bad Request

Edit: but these two commands are okay:

$ hg clone https://bitbucket.org/osrf/gazebo-release
$ hg clone https://bitbucket.org/osrf/gazebo_models

And I can download the fuerte or john release ZIP file from the downloads page.

BitBucket has had some weird errors like this before... can someone try the commands please?

2013-01-14 05:25:33 -0500 asked a question Modifying OpenNI Kinect plugin to get back disparity data again? gazebo_ros_openni_kinect.so

https://code.ros.org/trac/ros-pkg/browser/stacks/simulator_gazebo/trunk/gazebo_plugins/src/gazebo_ros_openni_kinect.cpp

Hi all,

I thought this was the most appropriate place to post this.

If you look at the above plugin, the functionality to return disparity data was removed, as opposed to the deprecated driver.
** How can I modify this plugin to return disparity data?
I'm happy to help, I just don't understand what the blocker is.

Alternatively, can I run some processing nodes on ROS to generate disparity data?

Cheers,
David.

2013-01-14 05:16:25 -0500 received badge  Supporter (source)