Gazebo | Ignition | Community
Ask Your Question

Gregwar's profile - activity

2015-11-10 16:57:17 -0600 received badge  Famous Question (source)
2015-11-10 16:57:17 -0600 received badge  Notable Question (source)
2015-11-10 16:57:17 -0600 received badge  Popular Question (source)
2015-11-02 10:36:33 -0600 asked a question Requesting model pose with entity_info is slow

I would like to retrieve the model pose fast (50 hz would be nice), but it looks like the entity_info message takes long

The result of:

gz model -m myRobot -i

Is typically 20000 lines long and takes like 0.4s on my computer (it outputs the whole hierarchy of the robot)

What the good practice to do that?

2015-10-19 05:29:46 -0600 asked a question Messages: getting the joints torque

Hello,

Is there a way to get the current joints torque using (protobuf) message communication with gazebo?

2015-10-18 14:48:50 -0600 asked a question Gertting joints torque

Hello

Is it possible to get joint curent torque using the gazebo api messages?

2015-10-18 10:35:43 -0600 asked a question Estimating joint "consumption"

Hello I would like to know if there is a way to get the torque applied to rotate joints in order to estimate the consumption of a robot in the simulator? Is there such a thing in the API?

2015-10-18 10:34:02 -0600 asked a question Getting motor "consumption"

Hello I would like to know if there is a way to get the torque applied to rotate joints in order to estimate the consumption of a robot in the simulator? Is there such a thing in the API?

2015-10-08 14:00:25 -0600 received badge  Famous Question (source)
2015-09-23 19:31:28 -0600 received badge  Notable Question (source)
2015-09-23 02:04:44 -0600 received badge  Popular Question (source)
2015-09-23 01:52:50 -0600 commented answer Delete and (re)load a model
2015-09-22 21:19:07 -0600 received badge  Nice Question (source)
2015-09-22 12:38:31 -0600 received badge  Student (source)
2015-09-22 11:07:56 -0600 received badge  Editor (source)
2015-09-22 11:07:22 -0600 asked a question Delete and (re)load a model

Hello, I would like to do experiments programatically, where I:

  1. Load a (sdf) robot model
  2. Do some simulation with it
  3. Unload this model
  4. Go back to 1. with another model file

And this a LOT of times. However, I'm experiencing strange behaviours. For instance, if I do the following:

gz model -m robot -f /path/to/robot.sdf
gz model -m robot -d
gz model -m robot -f /path/to/robot.sdf

Gazebo freezes and crash.

It looks like that -d doesn't actually deletes the model, since I can still see topics about it when gz topic -l

Do you have any idea?