Gazebo | Ignition | Community
Ask Your Question

Vaibhav Kapoor's profile - activity

2018-11-19 01:29:18 -0600 received badge  Nice Answer (source)
2018-10-12 04:33:15 -0600 received badge  Self-Learner (source)
2018-10-12 04:33:15 -0600 received badge  Teacher (source)
2015-03-05 19:43:33 -0600 received badge  Student (source)
2013-10-30 03:03:25 -0600 received badge  Taxonomist
2013-05-27 09:24:15 -0600 received badge  Famous Question (source)
2013-03-20 09:11:04 -0600 received badge  Notable Question (source)
2013-03-07 00:37:32 -0600 received badge  Famous Question (source)
2013-03-05 13:40:33 -0600 received badge  Popular Question (source)
2013-02-18 01:38:41 -0600 received badge  Notable Question (source)
2013-02-17 18:51:49 -0600 answered a question Gazebo model jittering

Hi I had started removing every single component until the jitterring had stopped. The very first link was even jitterring, I realized that maybe it's the inertia's that I had not setup yet. So I just put some reasonable values and it looks like the model is not jitterring any longer.

I also had to make sure the wheels had inertia as well, also the high friction coefficient that I got from the Golf Cart vehicle.

Thank you.

2013-02-16 22:49:09 -0600 received badge  Editor (source)
2013-02-16 22:47:29 -0600 asked a question TransformBroadcaster and Gazebo plugins

Hi, I have been wanting to get various Gazebo plugins working with ROS using SDF format, starting with Differential Drive plugin. I had some small success getting Twist messages to change joint states, but now I want to get odometry working. I have just pieced together what I could from erraticgazeboplugins and the DRCSim plugins.

DiffDriveROSPlugin.cpp

this->transformBroadcaster = new tf::TransformBroadcaster();

Any time I want to declare a TransformBroadcaster type I get this error:

gazebo: symbol lookup error:

/home/thelegace/fuerteworkspace/alesrobot/ales_msgs/lib/libDiffDriveROSPlugin.so: undefined symbol: _ZN2tf20TransformBroadcasterC1Ev

If I comment out the transform broadcaster instantiation my plugin loads fine. The pioneer2dx model file.

Please let know if there any issue with the code or anything else that I am doing.

2013-02-14 14:46:31 -0600 received badge  Popular Question (source)
2013-02-13 10:59:36 -0600 asked a question Gazebo model jittering

Hi, I managed to finally catch up with all the great development happening. I have put my model on this repository in the alesdescription/models/alesrobot folder. https://bitbucket.org/TheLegace/ales_...

I had made joints for my four wheeled robot, but for some reason it seems to be moving or jitterring on its own. It's noticeable and I am assuming the pose is changing. There is no plug in enabled so I cannot for the life of me understand why the model is moving.

If you would like me to upload the model anywhere else please let me know.

Thank you.