Gazebo | Ignition | Community
Ask Your Question

Mohsen Hk's profile - activity

2020-12-14 16:16:06 -0500 received badge  Famous Question (source)
2015-10-31 12:31:05 -0500 marked best answer GZServer problem >> Could not open file[empty.world]

I have ubuntu 12.04 and installed gazebo by Pre-compiled binaries from here

i don't any change in bashrc expect:

source /usr/share/gazebo/setup.sh

mohsen@mohsen-ThinkPad-R500:~$ gdb --args gzserver empty.world

GNU gdb (Ubuntu/Linaro 7.4-2012.02-0ubuntu2) 7.4-2012.02
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>...
Reading symbols from /usr/bin/gzserver...Reading symbols from /usr/lib/debug/usr/bin/gzserver-
1.5.0...done.
done.

(gdb) run

Starting program: /usr/bin/gzserver empty.world
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffe5293700 (LWP 4328)]
Gazebo multi-robot simulator, version 1.5.0
Copyright (C) 2013 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

Error [Server.cc:238] Could not open file[empty.world]
[Thread 0x7fffe5293700 (LWP 4328) exited]
[Inferior 1 (process 4252) exited with code 0377]
(gdb)

mohsen@mohsen-ThinkPad-R500:~$ echo $GAZEBORESOURCEPATH

/usr/share/gazebo-1.5:/usr/share/gazebo_models

and there is my empty.world: /usr/share/gazebo-1.5/worlds/empty.world

2015-10-31 12:31:05 -0500 marked best answer gazebo on ubuntu 11.10 (Oneiric)?

Hi guys :)

  1. can i install GAZEBO on UBUNTU 11.10 (Oneiric Ocelot) and ros fuerte form gazebosim.org?

  2. which version?

  3. do you have any link?

tnx

2015-10-31 12:31:05 -0500 marked best answer sudo apt-get install gazebo > gazebo : Depends: ... but it is not installable

Hi, How can i fix this problem? tnx

mohsen@mohsen-ThinkPad-R500:~$ sudo apt-get install gazebo

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:

gazebo : Depends: libboost-thread1.49.0 but it is not installable

      Depends: libboost-signals1.49.0 but it is not installable

      Depends: libboost-system1.49.0 but it is not installable

      Depends: libboost-filesystem1.49.0 but it is not installable

      Depends: libboost-program-options1.49.0 but it is not installable

      Depends: libboost-regex1.49.0 but it is not installable

      Depends: libboost-iostreams1.49.0 but it is not installable

      Depends: libcegui-mk2-0.7.6 but it is not installable

E: Unable to correct problems, you have held broken packages.

mohsen@mohsen-ThinkPad-R500:~$

2015-10-31 12:31:04 -0500 marked best answer Problem to install GAZEBO in Synaptic

Hi! when i "Mark" "ros-fuerte-simulator-gazebo" in "Synaptic" when this package "is not installed" (in status!), wanna "to be removed" some ROS packages in list, when i click "mark". it gave me this error:

Can't Mark All Packages For Installation Or Upgrade

ros-fuerte-simulator-gazebo: Depends: ros-fuerte-bullet (=2.79-s1359841903~precise) but 2.79-s1359842349~oneiric is to be installed

Depends: ros-fuerte-common-msgs (=1.8.13-0precise-20130203-0848-+0000) but 1.8.13-0oneiric-20130203-0846-+0000 is to be installed

Depends: ros-fuerte-common-rosdeps (=1.2.0-s1359838704~precise) but 1.2.0-s1359839413~oneiric is to be installed

Depends: ros-fuerte-driver-common but it is not going to be installed

Depends: ros-fuerte-geometry but it is not going to be installed

Depends: ros-fuerte-image-common but it is not going to be installed

Depends: ros-fuerte-nodelet-core (=1.6.5-s1359894314~precise) but 1.6.5- s1359892967~oneiric is to be installed

Depends: ros-fuerte-perception-pcl but it is not going to be installed

Depends: ros-fuerte-robot-model but it is not going to be installed

Depends: ros-fuerte-ros (=1.8.10-0precise-20130202-2019-+0000) but 1.8.10-0oneiric-20130202-2019-+0000 is to be installed

Depends: ros-fuerte-ros-comm (=1.8.15-0precise-20130203-0847-+0000) but 1.8.15-0oneiric-20130203-0849-+0000 is to be installed

Depends: ros-fuerte-visualization-common (=1.8.4-s1359883358~precise) but 1.8.4-s1359886951~oneiric is to be installed

Depends: ros-fuerte-xacro (=1.6.1-s1359883505~precise) but 1.6.1-s1359888901~oneiric is to be installed

Depends: ros-fuerte-protobuf (=0.1.0-s1359883067~precise) but 0.1.0-s1359886619~oneiric is to be installed

what am i shoud to do?

2015-10-31 12:30:18 -0500 marked best answer not found problem on cmake -DCMAKE_BUILD_TYPE=DEBUG ../

mohsen@mohsen-ThinkPad-R500:~/gazebo-1.4.0/build$ cmake -DCMAKEBUILDTYPE=DEBUG ../

-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Gazebo version 1.4.0
-- Found CPack generators: DEB
-- Found Doxygen: /usr/bin/doxygen 


====== Finding 3rd Party Packages ======

-- Operating system is Linux
-- checking for module 'freeimage>='
Must specify package names on the command line
--   package 'freeimage>=' not found
--   freeimage.pc not found, trying freeimage_include_dir and freeimage_library_dir flags.
--   Looking for FreeImage.h - found
--   Looking for libfreeimage - found
-- Found PROTOBUF: /usr/lib/libprotobuf.so 
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so
-- Looking for XOpenDisplay in /usr/lib/x86_64-linux-gnu/libX11.so;/usr/lib/x86_64-linux-gnu/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/x86_64-linux-gnu/libX11.so
-- Found OpenGL: /usr/lib/libGL.so 
-- checking for module 'libcurl'
--   found libcurl, version 7.21.6
-- checking for module 'libprofiler'
--   package 'libprofiler' not found
-- Looking for libprofiler - not found
-- checking for module 'libtcmalloc'
--   package 'libtcmalloc' not found
-- Looking for libtcmalloc - not found
-- checking for module 'CEGUI'
--   found CEGUI, version 0.6.2
-- checking for module 'CEGUI-OGRE'
--   package 'CEGUI-OGRE' not found
-- Looking for CEGUI, found
--  CEGUI-OGRE not found, opengl GUI will be disabled.
-- checking for module 'bullet'
--   package 'bullet' not found
-- Looking for tinyxml.h - found
-- Looking for libtar.h - found
-- checking for module 'tbb'
--   found tbb, version 3.0+r018
-- checking for module 'OGRE-RTShaderSystem>=1.7.1'
--   found OGRE-RTShaderSystem, version 1.7.3
-- checking for module 'OGRE>=1.7.1'
--   found OGRE, version 1.7.3
-- checking for module 'OGRE-Terrain'
--   found OGRE-Terrain, version 1.7.3
-- checking for module 'libswscale'
--   found libswscale, version 2.0.0
-- checking for module 'libavformat'
--   found libavformat, version 53.3.0
-- checking for module 'libavcodec'
--   found libavcodec, version 53.6.0
--  urdfdom_headers not found, urdf parser will not be built.
--  urdfdom not found, urdf parser will not be built.
--  console_bridge not found, urdf parser will not be built.
-- checking for modules 'playercore>=3.0;playerc++'
--   package 'playercore>=3.0' not found
--  Player not found, gazebo plugin for player will not be built.
-- checking for module 'gts'
--   package 'gts' not found
--  GNU Triangulation Surface library not found - Gazebo will not have CSG support.
-- checking for module 'bullet'
--   package 'bullet' not found
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt4: /usr/bin/qmake (found version "4 ...
(more)
2015-10-31 12:13:08 -0500 marked best answer How could I "remove" installed "Tarball" version of Gazebo?

Hi :) i installed Tarballversion of GAZEBO (gazebo-1.4.0.tar.bz2) from http://gazebosim.org/assets/distribut... like http://gazebosim.org/wiki/1.3/install on ubuntu 11.10 and Ros Fuerte. now i wanna remove it because I wanna install another version of GAZEBO (gazebo-dbg1.4.0amd64.deb). How can i do?

2014-01-20 05:45:22 -0500 received badge  Famous Question (source)
2013-09-19 10:10:20 -0500 received badge  Famous Question (source)
2013-07-30 23:48:55 -0500 received badge  Stellar Question (source)
2013-07-25 07:27:44 -0500 received badge  Favorite Question (source)
2013-07-23 19:07:59 -0500 received badge  Notable Question (source)
2013-07-20 07:28:58 -0500 received badge  Taxonomist
2013-06-25 20:02:24 -0500 received badge  Famous Question (source)
2013-06-12 15:58:23 -0500 received badge  Famous Question (source)
2013-05-27 19:09:58 -0500 received badge  Popular Question (source)
2013-04-30 02:27:05 -0500 received badge  Famous Question (source)
2013-04-02 15:00:42 -0500 received badge  Student (source)
2013-03-27 22:25:20 -0500 received badge  Famous Question (source)
2013-03-26 17:28:43 -0500 received badge  Notable Question (source)
2013-03-25 14:01:49 -0500 received badge  Famous Question (source)
2013-03-25 13:30:17 -0500 asked a question make error > depends on non-existent package gazebo

i have gazebo , i installed gazebo with synaptic and i can open it with "$gazebo" in terminal. when i make hectorgazeboplugins package, it gave me this error :( any body help?

mohsen@mohsen-ThinkPad-R500:~/fuerte_workspace/tu-darmstadt-ros-pkg/hector_gazebo/hector_gazebo_plugins$ make
mkdir -p bin
cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=`rospack find rosbuild`/rostoolchain.cmake  ..
[rosbuild] Building package hector_gazebo_plugins
Failed to invoke /opt/ros/fuerte/bin/rospack deps-manifests hector_gazebo_plugins
[rospack] Error: package/stack hector_gazebo_plugins depends on non-existent package gazebo


CMake Error at /opt/ros/fuerte/share/ros/core/rosbuild/public.cmake:129 (message):



  Failed to invoke rospack to get compile flags for package
  'hector_gazebo_plugins'.  Look above for errors from rospack itself.
  Aborting.  Please fix the broken dependency!

Call Stack (most recent call first):
  /opt/ros/fuerte/share/ros/core/rosbuild/public.cmake:203 (rosbuild_invoke_rospack)
  CMakeLists.txt:12 (rosbuild_init)


-- Configuring incomplete, errors occurred!
make: *** [all] Error 1
mohsen@mohsen-ThinkPad-R500:~/fuerte_workspace/tu-darmstadt-ros-pkg/hector_gazebo/hector_gazebo_plugins$
2013-03-23 06:31:31 -0500 commented answer What Is The Best Way to0 Learn GAZEBO in ROS For Beginners?

thank you friends :)

2013-03-22 10:15:37 -0500 received badge  Notable Question (source)
2013-03-21 16:17:58 -0500 commented answer What Is The Best Way to0 Learn GAZEBO in ROS For Beginners?

Hi :) tnx! i read Ros beginner level tutorials from here >> http://www.ros.org/wiki/ROS/Tutorials but now i wanna learn gazzebo first, then use ROS interface for. i find some link for next step : (http://gazebosim.org/wiki/Tutorials#GazeboVersion1.5) , (http://gazebosim.org/userguide/) , (http://gazebosim.org/wiki/MainPage) , (http://www.ros.org/wiki/gazebo) , (http://www.ros.org/wiki/simulatorgazebo) , (http://www.ros.org/wiki/simulatorgazeb). what is your idea if i wanna learn in order?

2013-03-21 13:54:17 -0500 received badge  Popular Question (source)
2013-03-20 16:45:43 -0500 asked a question What Is The Best Way to0 Learn GAZEBO in ROS For Beginners?

i am beginner and i wanna learn how can I use gazebo in ros. i installed gazebo 1.5.0 in synaptic.

in http://gazebosim.org/wiki/1.5/install wroted:

Only install Gazebo from here, and only follow tutorials from this website. Documentation on ros.org for Gazebo is old and not actively maintained.

and i wanna work gazebo with ros interface, but i'm confused! cus there is another tutorial for gazebo here >> http://www.ros.org/wiki/simulator_gazebo/Tutorials

what is your idea?

2013-03-20 15:11:12 -0500 edited question Gazebo GUI crashed immediately on start!

Hi :)

after i install gazebo on ubuntu 11.10 with Tarball. after install, i trying to type "gazebo" on terminal:

mohsen@mohsen-ThinkPad-R500:~$ gazebo

Gazebo multi-robot simulator, version 1.4.0

Copyright (C) 2013 Open Source Robotics Foundation.

Released under the Apache 2 License.

http://gazebosim.org

Gazebo multi-robot simulator, version 1.4.0

Copyright (C) 2013 Open Source Robotics Foundation.

Released under the Apache 2 License.

http://gazebosim.org

Msg Waiting for master.Msg Waiting for master

Msg Connected to gazebo master @ http://127.0.0.1:11345

Msg Publicized address: 192.168.14.139

Msg Connected to gazebo master @ http://127.0.0.1:11345

Msg Publicized address: 192.168.14.139

(gazebo:5099): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

mohsen@mohsen-ThinkPad-R500:~$

my gazebo gui show and exit immedietly without any error or warning!

what am i shoud to0 do0? :)

===============================================================

after i installed "gtk2-engines-pixbuf" by synaptic, it didn,t any error or warning but my gazebo shut down immediately after call!

gmohsen@mohsen-ThinkPad-R500:~$ gazebo

Gazebo multi-robot simulator, version 1.4.0

Copyright (C) 2013 Open Source Robotics Foundation.

Released under the Apache 2 License.

http://gazebosim.org

Gazebo multi-robot simulator, version 1.4.0

Copyright (C) 2013 Open Source Robotics Foundation.

Released under the Apache 2 License.

http://gazebosim.org

Msg Waiting for master.Msg Waiting for master

Msg Connected to gazebo master @ http://127.0.0.1:11345

Msg Publicized address: 192.168.1.51

Msg Connected to gazebo master @ http://127.0.0.1:11345

Msg Publicized address: 192.168.1.51

mohsen@mohsen-ThinkPad-R500:~$

===============================================================

* i re install ubuntu ,but 12.04 64bit! and try to0 install pre-compile binary gazebo with "synaptic" but still i have this problem! :( *

===============================================================

mohsen@mohsen-ThinkPad-R500:~$ gdb --args gzserver empty.world

GNU gdb (Ubuntu/Linaro 7.4-2012.04-0ubuntu2.1) 7.4-2012.04
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>...
Reading symbols from /usr/bin/gzserver...Reading symbols from /usr/lib/debug/usr/bin/gzserver-1.5.0...done.
done.

(gdb) run

Starting program: /usr/bin/gzserver empty.world
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffe5289700 (LWP 2511)]
Gazebo multi-robot simulator, version 1.5.0
Copyright (C) 2013 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

[New Thread 0x7fffe4a88700 (LWP 2512)]
[New Thread 0x7fffdffff700 (LWP 2513)]
Msg Waiting for master
Msg Connected to gazebo master @ http://127.0.0.1:11345
Msg Publicized address: 192.168.1.52
[New Thread 0x7fffd6a68700 (LWP 2515)]
[New Thread 0x7fffd6267700 (LWP 2516)]
[New Thread 0x7fffd5866700 (LWP 2517)]
[New Thread 0x7fffd4c43700 (LWP 2518)]
[New Thread 0x7fffc3fff700 (LWP 2522)]
[New Thread 0x7fffc37fe700 (LWP ...
(more)