Gazebo | Ignition | Community
Ask Your Question

Weiwei's profile - activity

2017-07-09 07:42:10 -0600 received badge  Notable Question (source)
2017-07-09 07:42:10 -0600 received badge  Popular Question (source)
2017-01-04 22:32:16 -0600 commented answer Gazebo System Requirements

@nkoenig Great. So Nvidia Graphic Card only enhances the rendering assignments?

2017-01-04 16:52:42 -0600 commented answer Gazebo System Requirements

@nkoenig Thank you for your kind reply. Would the Nvidia Graphic Card will speed up the rendering or ODE calculation? or all the ODE burden is for CPUs?

2017-01-04 00:26:15 -0600 received badge  Famous Question (source)
2017-01-03 19:38:36 -0600 commented question Gazebo System Requirements

@Lyndwyrm Thank you for your reply. :)

2017-01-03 06:20:49 -0600 received badge  Notable Question (source)
2017-01-03 06:20:49 -0600 received badge  Popular Question (source)
2017-01-01 19:02:14 -0600 asked a question Gazebo System Requirements

Hi all,

I intend to buy a new laptop and configure a PC and wish to run Gazebo under Ubuntu. My experiments background are quadrotors swarm (more than 15 vehicles) whose software is based on PX4 SITL with Gazebo6.6.

I searched the internet and found the similar answers,

But these answers were little outmoded and I would like to know that

  • Whether NVIDIA GeForce is the bottleneck for Gazebo performance (real-time factor)?
  • On your experience related to Gazebo-based UAV Swarm Simulation, which type processor and graphic card are recommended?
2016-10-22 07:20:50 -0600 asked a question SDF model initializes failed in Gazebo 6, but success after retrying `roslaunch`

Problem

When I tried to spawn an SDF model into Gazebo through (already doing source devel/setup.bash)

roslaunch polaris_simple_control_plugin empty_world.launch

the SDF model initializes failed sometimes.

  • Some partitions lost image description
  • Or the vehicle runs away quickly in the Gazebo world

After quitting the Gazebo and doing roslaunch again,

we could get the normal model as shown in the following image

image description

  • all parts appears correctly
  • the vehicle stops in the world until we send command to it.

System

  • Ubuntu 14.04
  • Gazebo 6
  • ROS Jade

Source Code

The source code is at

https://github.com/weiweikong/polaris...

The SDF model is at https://github.com/weiweikong/polaris...

Questions

I googled on above situations but didn't get anything that looked promising.

  • Is this situation a version conflict between ROS Jade and Gazebo 6?
  • Is this related to SDF model loading sequences?
  • How could we avoid this situation correctly?

Thanks!

2016-06-16 06:36:57 -0600 received badge  Enthusiast
2016-05-30 10:20:20 -0600 commented answer How to Improve the Simulation Performance

Great answer. What are the sneaky tricks as you mentioned? I also tried to upgrade my hardware, so which part of the hardware is crucial for Gazebo loading time.

2016-05-29 14:51:20 -0600 commented question How to set GAZEBO_PLUGIN_PATH correctly and add the plugin into Gazebo_ros ?

Can you check out the current GAZEBO_PLUGIN_PATH? Run $echo $GAZEBO_PLUGIN_PATH to see whether the path is right.