Home | Tutorials | Wiki | Issues
Ask Your Question

hari1234's profile - activity

2020-06-03 05:56:36 -0500 received badge  Famous Question (source)
2020-06-03 05:56:36 -0500 received badge  Notable Question (source)
2020-05-21 11:22:45 -0500 marked best answer why do models vibrate when spawned into gazebo?

So many times as i've realized , why are the robots moving / vibrating themselfs inside gazebo? This is not good for a simulator... how can this be removed? For example right now i was watching this valkyrine robot in gazebo, and it is vibrating everything like it is afraid of something. so i asked right now.

2020-04-30 14:18:42 -0500 received badge  Famous Question (source)
2020-04-30 03:40:20 -0500 received badge  Famous Question (source)
2020-04-30 03:40:20 -0500 received badge  Popular Question (source)
2020-04-30 03:40:20 -0500 received badge  Notable Question (source)
2020-02-26 03:26:15 -0500 received badge  Famous Question (source)
2019-11-14 04:04:56 -0500 asked a question Correct way to use track wheel in ugv

Correct way to use track wheel in ugv What is the correct way to add tracked wheel in gazebo? I couldn't find the proper

2019-11-12 05:10:43 -0500 asked a question How to use track wheel in my robot

How to use track wheel in my robot How do i add track wheel in my robot properly?

2019-11-06 19:24:33 -0500 received badge  Famous Question (source)
2019-08-27 10:49:47 -0500 received badge  Notable Question (source)
2019-08-27 10:49:47 -0500 received badge  Famous Question (source)
2019-03-17 08:12:50 -0500 received badge  Famous Question (source)
2019-03-17 08:12:50 -0500 received badge  Notable Question (source)
2019-03-05 18:43:42 -0500 received badge  Notable Question (source)
2019-03-05 18:43:42 -0500 received badge  Famous Question (source)
2019-01-04 03:37:28 -0500 asked a question Gimbal not working in X4 robot

Gimbal not working in X4 robot I tried to add gimbal mechanism in X4 robot by modifying some x4 robot xacro but i'm alwa

2018-11-25 07:26:59 -0500 received badge  Notable Question (source)
2018-11-21 03:57:46 -0500 received badge  Popular Question (source)
2018-11-20 10:26:08 -0500 marked best answer X4 laser sensor limited range

After i run command "X4_SENSOR_CONFIG_4=1 roslaunch subt_example team.launch", the range of the laserscan in only coming less than than 1 as also shown by below screenshot: image description This was happening for the X2 robot also when i used command: "X2_SENSOR_CONFIG_3=1 roslaunch subt_example team.launch": image description But after i replaced the sensor part of the planar_lidar.urdf.xacro file with below code the range is coming fine for X2 robot:

<sensor type="ray" name="${name}">
  <pose>0 0 0 0 0 0</pose>
  <visualize>false</visualize>
  <update_rate>40</update_rate>
  <ray>
    <scan>
      <horizontal>
        <samples>720</samples>
        <resolution>1</resolution>
        <min_angle>-1.570796</min_angle>
        <max_angle>1.570796</max_angle>
      </horizontal>
    </scan>
    <range>
      <min>0.10</min>
      <max>30.0</max>
      <resolution>0.01</resolution>
    </range>
    <noise>
      <type>gaussian</type>
      <mean>0.0</mean>
      <stddev>0.01</stddev>
    </noise>
  </ray>
   <plugin name="gazebo_ros_planar_lidar" filename="libgazebo_ros_laser.so">
      <topicName>${topic}</topicName>
      <frameName>${name}</frameName>
      <robotNamespace>${robot_namespace}</robotNamespace>
    </plugin>
</sensor>

But still the range of X4 laser scan is under 1. I am running system with 8 gb ram, 300 gb free HD, ubuntu 18.04, and ros melodic with gazebo 9 as described in catkin install tutorial of this subt repository. But im not using any dedicated nvidia gpu, i'm using i5 3rd gen intel cpu.

2018-11-20 09:35:39 -0500 commented answer X4 laser sensor limited range

Ok thanks, as you mentioned, the cpu based lase sensor was detecting the collision element also, so after i changed the

2018-11-20 00:38:01 -0500 asked a question X4 laser sensor limited range

X4 laser sensor limited range After i run command "X4_SENSOR_CONFIG_4=1 roslaunch subt_example team.launch", the range o

2018-11-16 03:29:23 -0500 received badge  Notable Question (source)
2018-11-16 03:29:23 -0500 received badge  Popular Question (source)
2018-11-15 01:05:30 -0500 asked a question difference level of using gpu and cpu for laser sensor

difference level of using gpu and cpu for laser sensor How much is the performance difference or the main difference bet

2018-11-14 08:50:36 -0500 edited question laser scan only giving -inf range values

laser scan only giving -inf range values laser scanner is only giving -inf range. i placed the robots in different posit

2018-11-14 08:48:40 -0500 asked a question laser scan only giving -inf range values

laser scan only giving -inf range values laser scanner is only giving -inf range. i placed the robots in different posit

2018-11-01 01:19:19 -0500 received badge  Famous Question (source)
2018-10-31 07:08:16 -0500 received badge  Famous Question (source)
2018-09-20 04:36:09 -0500 received badge  Famous Question (source)
2018-08-08 20:17:14 -0500 received badge  Famous Question (source)
2018-07-05 21:34:10 -0500 received badge  Famous Question (source)
2018-06-27 17:03:43 -0500 received badge  Famous Question (source)
2018-06-11 15:48:37 -0500 received badge  Notable Question (source)
2018-06-05 14:41:33 -0500 received badge  Notable Question (source)
2018-06-04 12:04:22 -0500 received badge  Popular Question (source)
2018-06-04 10:21:55 -0500 received badge  Popular Question (source)
2018-06-03 12:14:06 -0500 edited question all link comes to origin

all link comes to origin I am facing this issue again and again. Before i solved by modefing the inetia values, now i'm

2018-06-03 09:14:17 -0500 edited question all link comes to origin

all link comes to origin I am facing this issue again and again. Before i solved by modefing the inetia values, now i'm

2018-06-03 09:08:55 -0500 edited question all link comes to origin

all link comes to origin I am facing this issue again and again. Before i solved by modefing the inetia values, now i'm

2018-06-03 08:59:23 -0500 edited question all link comes to origin

all link comes to origin I am facing this issue again and again. Before i solved by modefing the inetia values, now i'm

2018-06-03 08:34:48 -0500 asked a question all link comes to origin

all link comes to origin I am facing this issue again and again. Before i solved by modefing the inetia values, now i'm

2018-06-02 22:14:14 -0500 edited question revolute joint not moving

revolute joint not moving when i'm sending the commands: rostopic pub -1 /blackBird/weapon_position_controller/command s

2018-06-02 22:13:29 -0500 asked a question revolute joint not moving

revolute joint not moving when i'm sending the commands: rostopic pub -1 /blackBird/weapon_position_controller/command s

2018-05-29 13:22:08 -0500 received badge  Notable Question (source)
2018-05-24 13:09:26 -0500 received badge  Popular Question (source)
2018-05-23 12:10:39 -0500 edited question link position not in correct position

link position not in correct position <robot name="blackBird"> <link name="body"> <visual>