Gazebo | Ignition | Community
Ask Your Question

alienmon's profile - activity

2018-10-05 14:08:30 -0600 received badge  Notable Question (source)
2018-10-05 14:08:30 -0600 received badge  Popular Question (source)
2018-06-27 08:58:10 -0600 received badge  Famous Question (source)
2018-02-28 12:20:38 -0600 received badge  Famous Question (source)
2018-02-28 12:20:38 -0600 received badge  Notable Question (source)
2017-08-28 09:19:43 -0600 received badge  Famous Question (source)
2017-08-23 21:17:48 -0600 marked best answer What does Gazebo use Random number generator for?

In this tutorial on Random Numbers, It says that

Gazebo makes use of a random number generator. By default its seed is set to PID But we can manually set the seed too

for example

Gazebo can be initialized with a random number seed on the command line using the --seed argument:

gazebo --seed <integer>

I tried the command gazebo --seed 9 Well, it opened gazebo , but I do not know what was changed or what was different.

I can't understand the tutorial. What is the random number for?? What does gazebo use it for? What if I change it?

I'm quite new in Gazebo, please help to explain.

2017-08-23 21:17:48 -0600 received badge  Scholar (source)
2017-08-23 21:17:37 -0600 received badge  Famous Question (source)
2017-08-23 10:05:08 -0600 commented answer What does Gazebo use Random number generator for?

@iche033 Thank you for your answer. Just to confirm..So a seed is where the random number starts from. Random number is

2017-08-22 12:31:18 -0600 received badge  Notable Question (source)
2017-08-22 09:13:47 -0600 received badge  Supporter (source)
2017-08-21 23:01:51 -0600 commented answer What does Gazebo use Random number generator for?

what is the meaning of specifying integer e.g. 9 as seed? Other than things you mentioned, the gazebo simulation will be

2017-08-21 22:59:12 -0600 received badge  Popular Question (source)
2017-08-21 13:35:33 -0600 received badge  Popular Question (source)
2017-08-21 13:34:52 -0600 received badge  Notable Question (source)
2017-08-21 13:34:52 -0600 received badge  Popular Question (source)
2017-08-20 03:34:33 -0600 edited question Could not open Gazebo using gazebo_ros

Could not open Gazebo using gazebo_ros I have followed this TUTORIAL to install gazebo_ros_pkgs I opted to install usin

2017-08-20 03:32:30 -0600 edited question Could not open Gazebo using gazebo_ros

Could not open Gazebo using gazebo_ros I have followed this TUTORIAL to install gazebo_ros_pkgs When I try to open the

2017-08-20 03:25:42 -0600 asked a question Could not open Gazebo using gazebo_ros

Could not open Gazebo using gazebo_ros I have followed this TUTORIAL to install gazebo_ros_pkgs When I try to open the

2017-08-19 06:59:18 -0600 received badge  Teacher (source)
2017-08-19 02:58:19 -0600 edited answer protobuf error for custom messages transport tutorial

I faced the same problem and finally was able to get it run. Here's how I fixed it: In the CMakeLists.txt under msgs fo

2017-08-19 02:57:29 -0600 answered a question protobuf error for custom messages transport tutorial

I faced the same problem and finally was able to get it run. Here's how I fixed it: In the CMakeLists.txt under msgs fo

2017-08-19 02:02:28 -0600 commented question protobuf error for custom messages transport tutorial

I am facing the same problem. Please help

2017-08-18 22:27:27 -0600 answered a question Problem with reading inertia values from sdf in Gazebo

It's actually fine. Gazebo has some limit decimal numbers. If you load your model using gazebo GUI and enter the edit m

2017-08-18 22:08:46 -0600 asked a question Razer Hydra controller tutorial : Unable to find razer device

Razer Hydra controller tutorial : Unable to find razer device I am following thus TUTORIAL I tried to run gazebo --verb

2017-08-18 07:34:57 -0600 asked a question What does Gazebo use Random number generator for?

What does Gazebo use Random number generator for? In this tutorial on Random Numbers, It says that Gazebo makes use

2017-08-18 07:28:59 -0600 received badge  Notable Question (source)
2017-08-18 02:18:23 -0600 commented question Problem in Building Robot - simple manipulator tutorial

Gazebo multi-robot simulator, version 7.0.0 I use gazebo 7, installed along with ROS KInetic. My Ubuntu is 16.04 @sloret

2017-08-16 07:44:39 -0600 edited question Problem in Building Robot - simple manipulator tutorial

Problem in Building Robot - simple manipulator tutorial I followed this tutorial on making a simple manipulator robot.

2017-08-16 07:43:29 -0600 asked a question Problem in Building Robot - simple manipulator tutorial

Problem in Building Robot - simple manipulator tutorial I followed this tutorial on making a simple manipulator robot.

2017-08-15 11:52:15 -0600 received badge  Popular Question (source)
2017-08-15 00:05:27 -0600 answered a question Tutorial: Intermediate: Connect to ROS - Laser is not spinning

I faced the same problem with you. It was because I needed to export the path first before running gazebo. As a result,

2017-08-14 22:12:01 -0600 commented question Gazebo system plugin tutorial problem: no frames saved

@iche033 I'm using gazebo 7 on Ubuntu 16, ROS Kinetic. You found the frames in /tmp/gazebo_frames folder?

2017-08-14 02:42:35 -0600 asked a question Gazebo system plugin tutorial problem: no frames saved

Gazebo system plugin tutorial problem: no frames saved I am doing gazebo system plug in tutorial ( link ) After running

2017-08-09 10:31:13 -0600 received badge  Notable Question (source)
2017-08-09 10:31:13 -0600 received badge  Popular Question (source)
2017-08-05 00:09:53 -0600 asked a question Model pose is inaccurate after resizing

Model pose is inaccurate after resizing I am following this beginner tutorial on model editor. I inserted a simple shap

2017-04-22 01:58:23 -0600 received badge  Famous Question (source)
2017-04-22 01:58:23 -0600 received badge  Notable Question (source)
2017-04-22 01:58:23 -0600 received badge  Popular Question (source)
2016-10-26 00:08:42 -0600 commented answer Virtual Machine not launching Gazebo

Thanks it solved my problem of not being able to open fetch robot in gazebo simulation! It's strange tho, cause I actually can other robots except for that particular robot.

2016-09-28 20:27:07 -0600 received badge  Enthusiast
2016-09-25 19:50:54 -0600 received badge  Editor (source)
2016-09-23 11:40:12 -0600 asked a question Spawn service timed out, sdf model deprecated?

I am trying to launch a model to gazebo, but it failed with the following message:

Deprecated: the -gazebo tag is now -sdf
[INFO] [WallTime: 1474618632.137629] [0.000000] Loading model xml from ros parameter
[INFO] [WallTime: 1474618632.139721] [0.000000] Waiting for service /gazebo/spawn_sdf_model
[INFO] [WallTime: 1474618632.141841] [0.000000] Calling service /gazebo/spawn_sdf_model
[INFO] [WallTime: 1474618642.275829] [915.469000] Spawn status: SpawnModel: Model pushed to spawn queue, but spawn service timed out waiting for model to appear in simulation under the name land_station1
[spawn_station1-1] process has finished cleanly
log file: /home/osboxes/.ros/log/eda84d90-8163-11e6-84be-000c29a1f7dd/spawn_station1-1*.log
all processes on machine have died, roslaunch will exit
shutting down processing monitor...
... shutting down processing monitor complete
done

I noticed it said "Deprecated: the -gazebo tag is now -sdf" and "SpawnModel: Model pushed to spawn queue, but spawn service timed out waiting for model to appear in simulation under the name land_station1"

I googled the error and found someone having same prob with me HERE

and it said that the problem is because: the urdf had some deprecated functions from old versions of gazebo.

Iam new to gazebo. Appreciate if you can help me to correct the sdf model:

<?xml version="1.0" ?>
<sdf version="1.4">
<model:physical name="land_station" 
  xmlns:xi="http://www.w3.org/2001/XInclude"
  xmlns:gazebo="http://playerstage.sourceforge.net/gazebo/xmlschema/#gz" 
  xmlns:model="http://playerstage.sourceforge.net/gazebo/xmlschema/#model" 
  xmlns:sensor="http://playerstage.sourceforge.net/gazebo/xmlschema/#sensor" 
  xmlns:window="http://playerstage.sourceforge.net/gazebo/xmlschema/#window" 
  xmlns:param="http://playerstage.sourceforge.net/gazebo/xmlschema/#param" 
  xmlns:body="http://playerstage.sourceforge.net/gazebo/xmlschema/#body" 
  xmlns:geo="http://willowgarage.com/xmlschema/#geo" 
  xmlns:geom="http://playerstage.sourceforge.net/gazebo/xmlschema/#geom" 
  xmlns:joint="http://playerstage.sourceforge.net/gazebo/xmlschema/#joint" 
  xmlns:interface="http://playerstage.sourceforge.net/gazebo/xmlschema/#interface" 
  xmlns:ui="http://playerstage.sourceforge.net/gazebo/xmlschema/#ui"
  xmlns:rendering="http://playerstage.sourceforge.net/gazebo/xmlschema/#rendering" 
  xmlns:renderable="http://playerstage.sourceforge.net/gazebo/xmlschema/#renderable" 
  xmlns:controller="http://playerstage.sourceforge.net/gazebo/xmlschema/#controller"
  xmlns:physics="http://playerstage.sourceforge.net/gazebo/xmlschema/#physics" >

   <xyz>0 0 0</xyz> 
   <rpy>0 0 0</rpy>
   <static>true</static>
   <body:trimesh name="landstation_body">
     <geom:trimesh name="landstation_geom">
       <scale>1.0 1.0 1.0</scale>
       <mesh>Marker1.dae</mesh>
       <genTexCoord>true</genTexCoord>
       <visual>
         <scale>1.0 1.0 1.0</scale>
         <mesh>Marker1.dae</mesh>

     <!--<material>Hector/BlueBrushedAluminum</material>-->
         <!--<material>Hector/Gouraud</material>-->
       </visual>
     </geom:trimesh>
   </body:trimesh>
</model:physical>
</sdf>

Anyone please?