Gazebo | Ignition | Community
Ask Your Question

bustun's profile - activity

2020-05-25 06:42:51 -0500 received badge  Student (source)
2020-04-23 17:10:47 -0500 received badge  Taxonomist
2017-05-02 06:58:40 -0500 received badge  Famous Question (source)
2017-05-02 06:58:40 -0500 received badge  Notable Question (source)
2017-02-07 14:27:24 -0500 received badge  Famous Question (source)
2017-02-07 14:27:24 -0500 received badge  Notable Question (source)
2017-01-28 14:28:37 -0500 received badge  Enthusiast
2017-01-27 07:43:53 -0500 received badge  Popular Question (source)
2017-01-26 13:24:25 -0500 received badge  Editor (source)
2017-01-26 13:23:49 -0500 answered a question GPU laser sensor reflects transparent glass material

I use Gazebo version 7.4 ROS Kinetic on Ubuntu 16.04

Below is the wall that is supposed not to reflect laser scans.

 <model name="glass1">
<static>true</static>
<pose>7 2 1 0 0 0</pose>
<link name="link">
  <collision name="visual">
     <laser_retro>0.5</laser_retro>
     <geometry><box><size>0.1 2 2</size></box></geometry>
  </collision>
  <visual name="visual1">
     <transparency>1</transparency>
     <geometry><box><size>0.1 2 2</size></box></geometry>
          <material>
          <script><name>Gazebo/RedTransparent</name></script>
         </material>
  </visual>
</link>

</model>

Here is the laser plugin definition:

<gazebo reference="hokuyo_link">
<material>Gazebo/Red</material>
<sensor type="gpu_ray" name="hokuyo">
 <pose>0 0 0 0 0 0</pose>
 <visualize>false</visualize>
 <update_rate>40</update_rate>
  <ray>
    <scan>
      <horizontal>
         <samples>720</samples>
          <resolution>1</resolution>
          <min_angle>-1.570796</min_angle>
          <max_angle>1.570796</max_angle>
      </horizontal>
    </scan>
    <range>
       <min>0.10</min> <max>30.0</max>
       <resolution>0.01</resolution>
    </range>
 </ray>
 <plugin name="gpu_laser" filename="libgazebo_ros_gpu_laser.so">
    <topicName>/scan</topicName>
    <frameName>hokuyo_link</frameName>
 </plugin>
</sensor>
</gazebo>
2017-01-26 06:16:16 -0500 asked a question GPU laser sensor reflects transparent glass material

Hello, I want to simulate a glass wall in Gazebo and see that the laser scanner can't detect it. In my model I tried to give different laser_retro and transparency settings. In Rviz I always see that the transparent wall reflects the laser scans. Can anybody shed some light on this ?


EDIT

I use Gazebo version 7.4 ROS Kinetic on Ubuntu 16.04

Below is the wall that is supposed not to reflect laser scans.

  <model name="glass1">
    <static>true</static>
    <pose>7 2 1 0 0 0</pose>
    <link name="link">
      <collision name="visual">
         <laser_retro>0.5</laser_retro>
         <geometry><box><size>0.1 2 2</size></box></geometry>
      </collision>
      <visual name="visual1">
         <transparency>1</transparency>
         <geometry><box><size>0.1 2 2</size></box></geometry>
              <material>
              <script><name>Gazebo/RedTransparent</name></script>
             </material>
      </visual>
    </link>
  </model>

Here is the laser plugin definition:

<gazebo reference="hokuyo_link">
<material>Gazebo/Red</material>
<sensor type="gpu_ray" name="hokuyo">
 <pose>0 0 0 0 0 0</pose>
 <visualize>false</visualize>
 <update_rate>40</update_rate>
  <ray>
    <scan>
      <horizontal>
         <samples>720</samples>
          <resolution>1</resolution>
          <min_angle>-1.570796</min_angle>
          <max_angle>1.570796</max_angle>
      </horizontal>
    </scan>
    <range>
       <min>0.10</min> <max>30.0</max>
       <resolution>0.01</resolution>
    </range>
 </ray>
 <plugin name="gpu_laser" filename="libgazebo_ros_gpu_laser.so">
    <topicName>/scan</topicName>
    <frameName>hokuyo_link</frameName>
 </plugin>
</sensor>
</gazebo>
2016-11-03 09:16:11 -0500 received badge  Popular Question (source)
2016-10-28 12:30:21 -0500 asked a question JointController doesn't move the joint

Hi, I created a simple robot model using urdf. In the urdf, there is a prismatic joint, which is supposed to move a link (a small box) vertically for position control.

joint values in urdf file : type="prismatic" limit effort="1000.0" lower="0" upper="2" velocity="1"

To move it vertically, I wrote a ROS aware gazebo plugin that takes the target position via ROS message. Then I used getJointController to move it like this:

my_model_->GetJointController()->SetPositionTarget(myJointName, 1.2);

my_model_->GetJointController()->SetPositionPID(myJointName, common::PID(2, 0, 1));

I just give a position target and filled the pid. not involved in effort, force or torque.

I tried my code in 2 different setup.

  1. virtualbox - ubuntu 16 - ros kinetic - gazebo 7.0

  2. virtualbox - ubuntu 16 - ros kinetic - gazebo 7.4

the code run on gazebo 7.0 without error and able to move the link as I wanted.

the code run on gazebo 7.4 without error but nothing moved.

Am I missing something or could it be related to a gazebo 7.4 issue ?