Gazebo | Ignition | Community
Ask Your Question

matwilso's profile - activity

2018-06-05 12:20:39 -0600 received badge  Enthusiast
2018-06-05 12:20:35 -0600 received badge  Enthusiast
2017-09-09 14:24:15 -0600 received badge  Critic (source)
2017-04-09 11:56:27 -0600 received badge  Scholar (source)
2017-03-30 07:01:24 -0600 received badge  Famous Question (source)
2017-03-28 06:23:13 -0600 received badge  Notable Question (source)
2017-03-28 06:23:13 -0600 received badge  Popular Question (source)
2017-03-23 23:20:34 -0600 asked a question Setting max speed of collisions

There are sharp edges in the imported collada mesh I am running my robot in and when the robot collides with the edges it gets launched in the air and flies far away.

Is there a parameter I can set to reduce the max speed or force imparted on the robot from collisions?

Thanks

2017-01-06 17:18:53 -0600 received badge  Supporter (source)
2016-12-27 10:47:51 -0600 received badge  Necromancer (source)
2016-12-27 10:47:51 -0600 received badge  Teacher (source)
2016-12-25 22:19:13 -0600 answered a question Can't load meshes correcly

You mesh imports are incorrect. To import meshes from ROS packages in Gazebo, you need to use the syntax:

<uri>model://my_package/meshes/foo.STL</uri>

For Gazebo to find your package, you also need to include the code block below in your package.xml. See this answer for more information.

<export>
<!-- gazebo_ros_paths_plugin automatically adds these to
    GAZEBO_PLUGIN_PATH and GAZEBO_MODEL_PATH when you do this export inside
    the package.xml file. You can than use URIs of type model://my_package/stuff. -->
    <gazebo_ros                                                                 
        gazebo_plugin_path="${prefix}/lib"
        gazebo_model_path="${prefix}/.." /> 
</export>