Gazebo | Ignition | Community
Ask Your Question

eed's profile - activity

2020-09-02 02:05:24 -0500 received badge  Famous Question (source)
2020-09-02 02:05:24 -0500 received badge  Notable Question (source)
2020-09-02 02:05:24 -0500 received badge  Popular Question (source)
2020-08-26 03:35:41 -0500 asked a question How to build a sdf model with complementary elements

How to build a sdf model with complementary elements I would like to build an sdf model with an square with an circular

2018-09-17 01:11:18 -0500 commented answer Build a world with different surfaces

I tried this. But the friction is not different even if I choose them different. For example I have one surface with fri

2018-09-17 01:10:00 -0500 edited question Build a world with different surfaces

Build a world with different surfaces Hi, I would like to create a world in Gazebo with different surfaces, like ice od

2018-09-17 01:04:00 -0500 commented answer Build a world with different surfaces

I tried this. But the friction is not different even if I choose them different. For example I have one surface with fri

2018-09-17 00:59:54 -0500 received badge  Famous Question (source)
2018-04-12 12:09:34 -0500 received badge  Notable Question (source)
2018-03-16 04:51:43 -0500 commented answer Build a world with different surfaces

Thanks, I will try it out

2018-03-16 04:51:29 -0500 received badge  Popular Question (source)
2018-03-16 02:02:22 -0500 received badge  Enthusiast
2018-03-15 05:22:23 -0500 edited question Build a world with different surfaces

Build a world with different surfaces Hi, I would like to create a world in Gazebo with different surfaces, like ice od

2018-03-15 05:18:46 -0500 asked a question Build a world with different surfaces

Build a world with different surfaces Hi, I would like to create a world in Gazebo with different surfaces, like ice od

2017-07-07 08:18:41 -0500 received badge  Famous Question (source)
2017-04-20 04:52:15 -0500 received badge  Supporter (source)
2017-04-19 04:58:37 -0500 commented answer Bug with colors loading from xacro in Gazebo 7

That worked for me. Thanks!

2017-04-19 00:49:36 -0500 received badge  Scholar (source)
2017-04-13 09:46:24 -0500 received badge  Notable Question (source)
2017-04-13 00:59:22 -0500 commented question Bug with colors loading from xacro in Gazebo 7

the link name is corrct. It worked in ros-indigo and gazebo 2 @sloretz what exactly you mean can I just add "<extra_gazebo_args value="verbose"/>" to the launch file? I posted my launch file above

2017-04-13 00:44:27 -0500 received badge  Popular Question (source)
2017-04-12 03:32:29 -0500 received badge  Editor (source)
2017-04-12 03:23:49 -0500 asked a question Bug with colors loading from xacro in Gazebo 7

In my model.xacro file there is:

<gazebo reference="top_plate">
  <material> Gazebo/Black </material>
</gazebo>

And I only get an white model. If I Edit the model in Gazebo7 and write 'Gazebo/Black' in Visusal/Material/Scrip/Name it works. I want it to be black while loarding. Has someboady an idea how to fix this bug.

My launch file:

<launch>

<include file="$(find gazebo_ros)/launch/empty_world.launch">
<!-- Note: the world_name is with respect to GAZEBO_RESOURCE_PATH environmental variable -->

  <arg name="world_name" value="worlds/empty.world"/> 
  <arg name="paused" value="false"/>
  <arg name="use_sim_time" value="true"/>
  <arg name="gui" value="true"/>
  <arg name="headless" value="false"/>
  <arg name="debug" value="false"/>
  <extra_gazebo_args value="verbose" />
</include>


<include file="$(find project_gazebo)/urdf/pioneer3at_kinect.xml" />

  <node name="spawn_p3dx" pkg="gazebo_ros" type="spawn_model" args="-urdf -param robot_description -model robot_description -x -0.0 -y -0.0 -z 0.051" respawn="false" output="screen" />

</launch>

My model file:

<?xml version="1.0"?>

<robot xmlns:sensor="http://playerstage.sourceforge.net/gazebo/xmlschema/#sensor"
   xmlns:controller="http://playerstage.sourceforge.net/gazebo/xmlschema/#controller"
   xmlns:interface="http://playerstage.sourceforge.net/gazebo/xmlschema/#interface"
   xmlns:xacro="http://ros.org/wiki/xacro"
>

<!-- Chassis -->
<link name="base_link">
    <inertial>
        <mass value="15.0"/>
        <origin xyz="0 0 0.10"/>
        <inertia ixx="0.3338" ixy="0.0" ixz="0.0"
             iyy="0.4783" iyz="0.0"
             izz="0.3338"/>
    </inertial>
    <visual name="base_visual">
        <origin xyz="0 0 0.177" rpy="0 0 0"/>
        <geometry name="pioneer_geom">
            <mesh filename="package://project_gazebo/meshes/p3at_meshes/chassis.stl"/>
        </geometry>
                   <material name="ChassisRed">
            <color rgba="0.851 0.0 0.0 1.0"/>
                   </material>
    </visual>
    <collision>
        <origin xyz="0 0 0.177" rpy="0 0 0"/>
            <geometry>
                <mesh filename="package://project_gazebo/meshes/p3at_meshes/chassis.stl"/>
            </geometry>
    </collision>
  </link>
  <gazebo reference="base_link">
    <visual>
      <material>
        <script>
          <name value="Gazebo/Red"/>
        </script>
      </material>
    </visual>
  </gazebo>
</robot>

And the Gazbeo look like: image description

2017-04-10 05:32:58 -0500 commented question Gazebo cannot start with camera

For me the same problem on Virtual Machine with Ubuntu 16.04 and Gazebo 7. Any solutions?