Gazebo | Ignition | Community
Ask Your Question

jacknlliu's profile - activity

2018-12-02 04:20:53 -0600 received badge  Famous Question (source)
2018-08-22 12:56:35 -0600 received badge  Famous Question (source)
2018-04-23 14:43:29 -0600 received badge  Famous Question (source)
2018-03-09 01:46:57 -0600 received badge  Famous Question (source)
2018-03-07 19:18:43 -0600 received badge  Notable Question (source)
2018-03-07 19:18:43 -0600 received badge  Popular Question (source)
2018-03-07 00:46:21 -0600 received badge  Enthusiast
2018-03-06 20:50:20 -0600 edited question gazebo set values of joint angles beyond the joint limits or `break` when robot contact with ground or some object

gazebo set values of joint angles beyond the joint limits or `break` when robot contact with ground or some object Gazeb

2018-03-06 20:49:32 -0600 asked a question gazebo set values of joint angles beyond the joint limits or `break` when robot contact with ground or some object

gazebo set values of joint angles beyond the joint limits or `break` when robot contact with ground or some object Gazeb

2018-02-13 16:59:32 -0600 received badge  Notable Question (source)
2018-02-13 16:59:32 -0600 received badge  Popular Question (source)
2017-12-17 08:27:38 -0600 received badge  Famous Question (source)
2017-11-08 23:07:48 -0600 commented answer How to simulate a compression spring

not work when set parent link as other link in the gazebo scene

2017-10-18 12:51:21 -0600 received badge  Notable Question (source)
2017-10-18 12:51:21 -0600 received badge  Popular Question (source)
2017-10-09 19:40:31 -0600 asked a question How to make gazebo which was recompiled from source works with ROS-desktop-full

How to make gazebo which was recompiled from source works with ROS-desktop-full I recompiled gazebo from source for ocul

2017-10-08 23:15:50 -0600 asked a question Gazebo sensor kinect link not exist in rviz

Gazebo sensor kinect link not exist in rviz I create a world file which including a kinect sensor with gazebo plugin for

2017-07-11 11:54:55 -0600 received badge  Notable Question (source)
2017-07-11 11:54:55 -0600 received badge  Popular Question (source)
2017-07-07 10:54:42 -0600 received badge  Notable Question (source)
2017-06-02 08:04:21 -0600 received badge  Popular Question (source)
2017-05-31 02:44:12 -0600 received badge  Editor (source)
2017-05-31 02:44:12 -0600 edited question Gazebo GUI not save model custom collision

Gazebo GUI not save model custom collision I open a my_task.world file with following command, $ gazebo my_task.world

2017-05-31 02:41:35 -0600 asked a question Gazebo GUI not save model custom collision

Gazebo GUI not save model custom collision I open a my_task.world file with following command, $ gazebo my_task.world

2017-05-30 21:38:44 -0600 marked best answer inertial settings not working

My world file my_task.world is:

<?xml version="1.0"?>
<sdf version="1.4">
<world name="default">
<include>
  <uri>model://ground_plane</uri>
</include>
<include>
  <uri>model://sun</uri>
</include>
<model name="my_mesh">
  <pose>0.2 0 0  0 0 0</pose>
  <static>true</static>
  <link name="pad_body">
    <inertial>
      <pose>0.315 0 0.0885 0 0 0</pose>
      <mass>100.0</mass>
      <inertia>
        <ixx>1.0</ixx>
        <ixy>0.0</ixy>
        <ixz>0.0</ixz>
        <iyy>1.0</iyy>
        <iyz>0.0</iyz>
        <izz>1.0</izz>
      </inertia>
    </inertial>
    <collision name="collision">
        <geometry>
            <mesh>
                <uri>model://visual/taskpad.dae</uri>
            </mesh>
        </geometry>
    </collision>
    <visual name="visual">
      <geometry>
        <mesh>
        <uri>model://visual/taskpad.dae</uri>
        </mesh>
      </geometry>
    </visual>
  </link>
</model>
</world>
</sdf>

But the inertial settings not working, after run the following command,

$ gazebo  my_task.world

gazebo always show its mass and moment of inertial as gazebo default values.

Any help will be appreciated!

2017-05-30 21:38:44 -0600 received badge  Scholar (source)
2017-05-30 09:50:44 -0600 asked a question inertial settings not working

inertial settings not working My world file my_task.world is: <?xml version="1.0"?> <sdf version="1.4"> &l