Home | Tutorials | Wiki | Issues
Ask Your Question

Vahid's profile - activity

2019-04-24 16:11:23 -0500 received badge  Famous Question (source)
2019-04-24 16:11:23 -0500 received badge  Notable Question (source)
2017-06-22 12:06:12 -0500 received badge  Popular Question (source)
2017-06-21 13:43:17 -0500 edited question Overlay gui is not invisible

Overlay gui is not invisible Hi everybody, I have a gui plugin which is so similar to one in gui overlay tutorial. the

2017-06-21 13:38:54 -0500 commented question Overlay gui is not invisible

yes, you are right. I did that. my current version is 8.1 which is the last version.

2017-06-21 12:05:48 -0500 received badge  Famous Question (source)
2017-06-21 12:02:57 -0500 asked a question Overlay gui is not invisible

Overlay gui is not invisible Hi everybody, I have a gui plugin which is so similar to one in gui overlay tutorial. the

2017-06-21 12:02:43 -0500 asked a question Overlay gui is not invisible

Overlay gui is not invisible Hi everybody, I have a gui plugin which is so similar to one in gui overlay tutorial. the

2017-06-21 06:07:29 -0500 received badge  Famous Question (source)
2016-09-21 21:06:36 -0500 received badge  Famous Question (source)
2015-10-31 12:30:27 -0500 marked best answer Change Color of Both Side of Wall

Hi Dear All,

I can change color of nistmazewll_240 with this tag

    <material>
      <ambient>1 0 0 1</ambient>
      <diffuse>1 0 0 1</diffuse>
      <specular>0.1 0.1 0.1 1</specular>
      <emissive>0 0 0 0</emissive>
    </material>

but, with this tag just color of one side changed! i want to change color of both side, i tried some tags but those didn't work! also i can rotate the wall but because of fault in saving environment i can't do that. any one can help me?

2015-10-31 12:30:27 -0500 marked best answer how to create map from simulated kinect!

Hi all,

I have a problem to understanding octree! i have a simulated robot with simulated kinect, also i have odometry data, so, now i have kinect data and position of robot, after this i want to create 3d map of environment with octree! what i need? my means what should i do, just i should publish data of kinect and position of robot to octree or any things else ?!!!! if my order for doing this is wrong please guide me in correct order! Thank you.

2015-10-31 12:30:26 -0500 marked best answer error in compile of plugin in stand alone gazebo

Dear my friends,

I've downloaded the plugins from this address, but when i run cmake.. i get this error

        root@vahid:~/plugin# cd build/
root@vahid:~/plugin/build# cmake ..
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Error at CMakeLists.txt:42 (gz_install_includes):
  Unknown CMake command "gz_install_includes".


-- Configuring incomplete, errors occurred!

what is my wrong ?

2015-10-31 12:30:26 -0500 marked best answer Extra Characters in output of Camera

Hi Dear all,

i don't know that it's my wrong or there is fault in libcameraplugin, when i run this command:

gztopic echo /gazebo/default/camera/link/camera/image

i got output with some extra characters for example:

time {
  sec: 848
  nsec: 746000000
}
image {
  width: 10
  height: 4
  pixel_format: 3
  step: 30
  data: "\246\265\335\243\262\334\240\260\332\236\255\331>>;\233\253\327\233\253\327\234\254\327\236\255\330\240\257\331\265\302\335\263\300\334\262\277\333764542\257\274\331\260\274\331\260\275\332\262\276\332\263\300\333\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214"

i don't know what is (>>; and 3376452) in above! or:

time {
  sec: 953
  nsec: 570000000
}
image {
  width: 10
  height: 4
  pixel_format: 3
  step: 30
  data: "\246\265\335\243\262\334\240\260\332xxx>>;xxx\233\253\327\234\254\327\236\255\330\240\257\331\265\302\335\263\300\334\262\277\333764542xxx\260\274\331\260\275\332\262\276\332\263\300\333\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214"
}

in above output, (xxx>>;xxx & 333764542xxx) are extra! any one know why i got some extra characters?!

2015-10-31 12:30:25 -0500 marked best answer send velocity command to wheels of pioneer3at in standalone version of gazebo

Hi all,

I installed standalone version of gazebo and i put a pioneer3at robot with laser scanner in environment, now i can get data of laser in my code but i don't know how can i send command to robot for moving in my code, i am new in gazebo and i want to test my navigation algorithm in simulated pioneer3at robot. i don't want to use ros, just i want to work with standalone version of gazebo, any one can help me?

2015-10-31 12:30:25 -0500 marked best answer subscribe to topic of laser in standalone version of gazebo

Hi all,

I installed standalone version of Gazebo and i put a simulated pioneer3at in the environment with laser scanner, and i can get data of laser in shell with this command

gztopic echo /gazebo/default/pioneer3at/hokuyo/link/laser/scan

but i want to subscribe to this topic like this, anyone can help me???

2015-10-31 12:30:08 -0500 marked best answer problem with loading gazebo in ros

Hi all,

I installed Ros hydro in ubuntu 12.04 and after that i followed the instructions for installing rosgazebo package, during installation i didn't have any problem, but now when i want run rosrun gazeboros gazebo, i've got following error

Gazebo multi-robot simulator, version 2.0.0
Copyright (C) 2013 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

Error [Plugin.hh:141] Failed to load plugin /opt/ros/hydro/lib/libgazebo_ros_paths_plugin.so: libgazebo_common.so.1: cannot open shared object file: No such file or directory
Error [Plugin.hh:141] Failed to load plugin /opt/ros/hydro/lib/libgazebo_ros_api_plugin.so: libgazebo_common.so.1: cannot open shared object file: No such file or directory
Msg Waiting for master
Gazebo multi-robot simulator, version 2.0.0
Copyright (C) 2013 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

Error [Plugin.hh:141] Failed to load plugin /opt/ros/hydro/lib/libgazebo_ros_paths_plugin.so: libgazebo_common.so.1: cannot open shared object file: No such file or directory
Msg Waiting for master
Msg Connected to gazebo master @ http://127.0.0.1:11345
Msg Publicized address: 192.168.2.10
Msg Connected to gazebo master @ http://127.0.0.1:11345
Msg Publicized address: 192.168.2.10

also i searched for this library, and just i found these

/usr/lib/libgazebo_common.so.2 
/usr/lib/libgazebo_common.so

any one can help me?!

2015-10-31 12:29:08 -0500 marked best answer reference to gazebo in documents

Dear my friends, Hello, I did my project, and now I'm writing my documents, so, please let me know how can i reference to Gazebo, i should reference just to website or there is any article or any other things?! i just this survey. also i find this article Thank you

2015-10-31 12:28:12 -0500 marked best answer my world is changed when i loaded it

Hi Dear All,

I create a world in Gazebo (Standalone Version 1.8) and I saved it, but when i load it, my world is changed?! any one know what is my fault?

for example i create this world but when i load it i have this world, I've marked the changed part.

i loaded my world with this command:

>gazebo name_of_saved_world

and i save the world from file menu (save world as).

I've attached a world with a box. test4.sdf

2015-10-31 12:13:19 -0500 marked best answer Can't Convert output of Camera to String

Dear All,

I have a big problem and i should solve it immediately, i want to do an image processing project, i add a camera sensor in gazebo (standalone gazebo 1.8.7 without ROS), and i can't get output of camera in my code, i can get out put of it in shell with gaztopic echo and gztopic view. i get output of others sensor with subscribe to their topics and i do same for camera but i can't get it!!! it's my code, I'm sure that my code is correct, but i don't know how can i convert output of camera to string?!!!!!!!!!

subLCam  = nodeLCam->Subscribe("~/pioneer3at/leftcamera/leftlink/camera/image", `&Manage::parseLCam, this);`

void Manage::parseLCam(ConstImageStampedPtr &_img)
{
    if ( MGDebug )
        qDebug()<<"<<<MG>>> In parseLEFTCam Function.";

    QString msg(_img->ShortDebugString().c_str());

    qDebug()<<msg;
}
2015-10-31 12:13:10 -0500 marked best answer i don't have vel_cmd topic in my gztopic list

all my dear friends, hello,

I run the gzserver and gzclient alone and without any parameter and after that i insert a pioneer3at robot with laser scanner in field, i want to drive robot in the field and based on my search i need to vel_cmd topic, but when i enter the gztopic lists, i get this output

root@vahid:/home/vahid# gztopic list
/gazebo/default/pose/info
/gazebo/default/gui
/gazebo/default/response
/gazebo/default/world_stats
/gazebo/default/selection
/gazebo/default/model/info
/gazebo/default/light
/gazebo/default/physics/contacts
/gazebo/default/visual
/gazebo/default/request
/gazebo/default/joint
/gazebo/world/modify
/gazebo/default/log/status
/gazebo/default/diagnostics
/gazebo/default/factory
/gazebo/default/model/modify
/gazebo/default/scene
/gazebo/default/physics
/gazebo/default/world_control
/gazebo/server/control
/gazebo/default/sensor
/gazebo/default/pioneer3at/hokuyo/link/laser/scan

why vel_cmd topic is not availability in my list ?! i don't want to use ros, just i want to work with standalone version of gazebo, any one can help me?

2015-10-31 12:13:10 -0500 marked best answer output of camera plugin in standalone gazebo

Hi all,

Dear Friends, i want to do a simple project and i need to image processing, i should say that i work with standalone version of gazebo (1.8) (without ROS), so, i inserted a camera in gazebo and i get output of it with this command:

> gztopic echo /gazebo/default/camera/link/camera/image

but i can't understand its output:

    time {
  sec: 17
  nsec: 449000000
}
image {
  width: 5
  height: 2
  pixel_format: 3
  step: 15
  data: "\255\273\336\250\267\333\246\264\332\246\265\332\251\267\333\214\214\214\214\214\214\214\214\214\214\214\214\214\214\214"
}

any one can explain the output? also i set width = 5 and height=2 in SDF file of camera. i want to know what is the pixel_format and step and order of data ?!

2015-10-31 12:12:56 -0500 marked best answer kineckt is not available in my rostopic list!!!

Hi all,

I installed Ros hydro along with Gazebo package(1.9) for Ros in ubuntu 12.04, i run gazebo with this command

rosrun gazebo_ros gazebo

and i add sensors like Hokyuo and kineckt, i can't see the topic of them in rostopic list, i know that i should add plugin for them but at first i don't know the format and specified plugin for them and after that i am not sure about the place that i should add plugin, my mean is, should i add plugin tag in SDF file of this sensors or other place? please if it is possible write the complete plugin tag for these sensors especially kineckt, I tried many times but those don't work!!!!

2015-10-31 12:12:29 -0500 marked best answer What is Groundtruth?!

Hi all,

Excuse me, i know there is not a good place to ask this question, just i hope anyone can help me! i read something about Groundtruth, but i can understand what is Groundtruth exactly?! also we can use it in gazebo with odometry data?!!! thank you!

2015-04-22 02:16:31 -0500 received badge  Famous Question (source)
2015-03-04 06:19:43 -0500 received badge  Famous Question (source)
2014-11-11 10:28:25 -0500 received badge  Famous Question (source)
2014-07-18 02:21:10 -0500 marked best answer change color of models

Hi Dear All,

I want to change color of models in gazebo ( standalone version 1.8.6 ), i read some comments here, but those don't work, by the way any one can help me? for example i want to change color of Cube 20k, and i don't know what is tag of color?!! and also i can't fine any property for color in gazebo! because i use standalone version of gazebo, i use SDF, for Example SDF file of Cube20k is:

<?xml version="1.0" ?>
<sdf version="1.4">
  <model name="cube_20k">
    <link name="link">
      <pose>0 0 0.5 0 0 0</pose>
      <collision name="collision">
        <geometry>
          <mesh>
            <uri>model://cube_20k/meshes/cube_20k.stl</uri>
            <scale>0.5 0.5 0.5</scale>
          </mesh>
        </geometry>
      </collision>
      <visual name="visual">
        <geometry>
          <mesh>
            <uri>model://cube_20k/meshes/cube_20k.stl</uri>
            <scale>0.5 0.5 0.5</scale>
          </mesh>
        </geometry>
      </visual>
    </link>
  </model>
</sdf>

i got this error when i added the material tag to SDF file:

XML Element[material], child of element[mesh] not defined in SDF. Ignoring.[mesh]
Error [parser.cc:710] Error reading element <mesh>
Error [parser.cc:710] Error reading element <geometry>
Error [parser.cc:710] Error reading element <collision>
Error [parser.cc:710] Error reading element <link>
Error [parser.cc:710] Error reading element <model>
Error [parser.cc:369] Unable to read element <sdf>
Error:   Could not find the 'robot' element in the xml file
         at line 61 in /tmp/buildd/ros-fuerte-urdfdom-0.2.3-3precise-20130312-1505/urdf_parser/src/model.cpp

I've added material tag to SDF file of Cube20K in this way, and now color of my Cube20k is changed

<?xml version="1.0" ?>
<sdf version="1.4">
  <model name="cube_20k">
    <link name="link">
      <pose>0 0 0.5 0 0 0</pose>
      <collision name="collision">
        <geometry>
          <mesh>
            <uri>model://cube_20k/meshes/cube_20k.stl</uri>
            <scale>0.5 0.5 0.5</scale>
          </mesh>
        </geometry>
      </collision>
      <visual name="visual">
        <geometry>
          <mesh>
            <uri>model://cube_20k/meshes/cube_20k.stl</uri>
            <scale>0.5 0.5 0.5</scale>
          </mesh>
        </geometry>
        <material>
          <ambient>1 0 0 1</ambient>
          <diffuse>1 0 0 1</diffuse>
          <specular>0.1 0.1 0.1 1</specular>
          <emissive>0 0 0 0</emissive>
        </material>
      </visual>
    </link>
  </model>
</sdf>
2014-07-03 15:52:23 -0500 marked best answer how to add sonar sensor to pioneer3at robot in standalone version of gazebo

Hi all,

I want to add sonar sensor to pioneer3at robot in standalone version of gazebo, i don't want to use ros, just i want to work with standalone version of gazebo and i want to test my navigation algorithm, how can i add sonar sensor to my simulated pioneer3at robot and how can i get data of it? can any one help me?

2014-07-03 15:11:06 -0500 received badge  Famous Question (source)
2014-06-02 05:21:01 -0500 received badge  Popular Question (source)
2014-06-02 05:21:01 -0500 received badge  Notable Question (source)
2014-04-26 17:34:53 -0500 received badge  Famous Question (source)
2014-01-20 04:32:06 -0500 received badge  Famous Question (source)
2013-12-11 22:26:49 -0500 received badge  Popular Question (source)
2013-12-11 22:26:49 -0500 received badge  Notable Question (source)
2013-11-29 06:51:31 -0500 received badge  Famous Question (source)
2013-11-21 13:35:39 -0500 commented question load multi object from world file

Yes, you are right the problem just was with the name, now my problem is solved.

2013-11-21 04:27:15 -0500 commented question load multi object from world file

Thank you for answering, no there is not any errors, also terminal output is like as usual, my gazebo version is 1.9.1.

2013-11-21 03:25:10 -0500 asked a question load multi object from world file

Hi Dear All,

I changed one of the world file to put some cubes in world but it doesn't work, when i run this world just one cube comes to world,

<?xml version="1.0" ?>
<sdf version="1.4">
  <world name="default">
    <!-- A global light source -->
    <include>
      <uri>model://sun</uri>
    </include>
    <!-- A ground plane -->
    <include>
      <uri>model://ground_plane</uri>
    </include>
    <!-- First Cube -->
    <include>
      <uri>model://cube_small</uri>
      <pose>-3 -3 0 0.0 0.0 0.0</pose>
    </include>
<!-- Second Cube -->
    <include>
      <uri>model://cube_small</uri>
      <pose>3 3 0 0.0 0.0 0.0</pose>
    </include>
  </world>
</sdf>

any one knows what is problem?

2013-11-13 04:00:10 -0500 received badge  Notable Question (source)