Gazebo | Ignition | Community
Ask Your Question

bot's profile - activity

2014-02-05 19:09:04 -0500 received badge  Taxonomist
2013-06-13 07:46:03 -0500 received badge  Famous Question (source)
2013-06-05 05:52:18 -0500 commented answer Importing collada meshes in gazebo

The problem is that i dont know where those materials are saved. There is a part of dae which is referencing materials, but I still cant tell where they are saved. I will edit my post later with that part. Thank you for your answer!

2013-06-05 05:49:47 -0500 received badge  Notable Question (source)
2013-06-04 06:16:06 -0500 received badge  Popular Question (source)
2013-06-01 09:12:35 -0500 asked a question Importing collada meshes in gazebo

I created a robot mesh in Blender, and now I want to import it in Gazebo. The problem is that, when I insert the model in Gazebo, the shape is good, but it is completely black, altought it had different colours in Blender. To color the object in Blender, I added some new materials. The result of exporting to collada was just robot.dae file. Maybe there should be some other files representing materials? The part of the SDF that imports mesh looks like this:

<geometry>
   <mesh><uri>file://robot.dae</uri></mesh>
</geometry>

...for both visual and collision tag.

2013-05-30 11:44:23 -0500 received badge  Editor (source)
2013-05-30 11:43:49 -0500 asked a question Model and sensor plugin in 1 sdf

I have sdf file defining a model and a sensor within the model. It looks something like this:

<model>
  ...
  <sensor>
    <plugin name="sensor_plugin" filename="...">
    ...
  </sensor>
  ...
  <plugin name="model_plugin" filename="...">
</model>

The problem is that they dont work both at the time. If I turn of* only model plugin, the sensor plugin works, and when I turn of sensor plugin, the other one works. When both sensors are turned on, only sensor plugin, which comes first in the sdf file, does work. Maybe I cant use both plugins at the same time? Or am I doing something wrong?

*turn on/of = comment/uncomment

2013-05-30 10:53:22 -0500 received badge  Famous Question (source)
2013-05-16 01:49:16 -0500 received badge  Notable Question (source)
2013-05-14 12:10:09 -0500 received badge  Popular Question (source)
2013-05-13 15:58:38 -0500 received badge  Supporter (source)
2013-05-13 15:07:54 -0500 received badge  Teacher (source)
2013-05-13 15:07:54 -0500 received badge  Self-Learner (source)
2013-05-13 13:57:24 -0500 answered a question Plugin/SDF problem; unable to find or open sdf file

I am going to answer my own question :). I forgot this part of installation: quick start. This line solved problem for me:

source /usr/share/gazebo[version]/setup.sh
2013-05-13 09:29:12 -0500 received badge  Student (source)
2013-05-12 15:33:05 -0500 asked a question Plugin/SDF problem; unable to find or open sdf file

Hello, I am trying to create my first Gazebo plugin. I tried to follow this tutorial - link, and this is the result (Gazebo was installed as pre-compiled binaries on Ubuntu 12.04.):

Gazebo multi-robot simulator, version 1.6.1 Copyright (C) 2013 Open Source Robotics Foundation. Released under the Apache 2 License. http://gazebosim.org

Error [parser.cc:69] Unable to find or open SDF file[] Error [Server.cc:247] Unable to initialize sdf