Gazebo | Ignition | Community
Ask Your Question

michou214's profile - activity

2018-11-21 14:56:50 -0600 marked best answer Problem of creating a model with texture and using a ros camera

Hello everyone,

I'm quite new in Gazebo and ROS but even after following tutorials and try to copy what is working, I get some weird results as shown in this picture : image description

I'm trying to create some model with a texture that would be an Apriltag (like QR code). I will explain all the steps I did to arrive a the picture above:

Step 0: In Gazebo, I add a cube and by using the "Model edit" mode, I transformed it into a small squared panel. When I saved it, it create my a new folder in my home: model_editor_models which contains the model (texture, material and so on). Now as you can see in the picture below there are more of them. They are my other tests. image description

Step 1: Then, after closing Gazebo, I launched it again and I add the model that I created/modified. I saved them in a file called Test_for_forum.world. image description

Step 2: I made a catkin_make in my project workspace (just to be sure but I know it changes nothing). I launch in differente terminal: roscore rosrun rqt_image_view rqt_image_view roslaunch waypoint_navigation main.launch And I get this: image description As we can see, the big box does not have anymore the Apriltag at the top. This is a first problem. I don't know why but it takes a long time to get an image in the rqt windows. When finally, it works, I obtain this result: image description

As you can see through the rqt window, the texture on the cube is white and there is no more the apriltag.The same thing happens on the small panel.

More precision the cube is just a copy/past of the folder that create the cube/sphere/cylinder with the colored texture. I just delete the sphere and cylinder in the model file and change the texture with mine.

Is there someone that have this problem ? Thanks in advance

2018-11-21 14:56:50 -0600 received badge  Scholar (source)
2018-11-16 15:55:30 -0600 received badge  Famous Question (source)
2018-11-16 01:52:25 -0600 answered a question Problem of creating a model with texture and using a ros camera

Hello, I found a solution and I'm pretty sure it is a problem of path. When I was creating my world with Gazebo, I get

2018-11-15 02:58:05 -0600 received badge  Notable Question (source)
2018-11-14 15:00:12 -0600 commented question Problem of creating a model with texture and using a ros camera

Okay let me know if it works with rosrun rqt_image_view rqt_image_view

2018-11-14 13:49:53 -0600 commented question Problem of creating a model with texture and using a ros camera

I changed the script because otherwise I can't precise which texture it should use. Yes it's a PNG that I generated usin

2018-11-14 13:48:12 -0600 commented question Problem of creating a model with texture and using a ros camera

Here you can find the files : https://github.com/michou214/Rendering_problem APtag folder is a copy of "textured_shapes

2018-11-14 13:47:59 -0600 commented question Problem of creating a model with texture and using a ros camera

Here you can find the files : https://github.com/michou214/Rendering_problem APtag folder is a copy of "textured_shapes

2018-11-14 13:47:34 -0600 commented question Problem of creating a model with texture and using a ros camera

textured_shapes folder is the official one that you can found in the Gazebo database. textured_shapes(copy) folder is th

2018-11-14 13:47:26 -0600 commented question Problem of creating a model with texture and using a ros camera

Here you can find the files : https://github.com/michou214/Rendering_problem APtag folder is a copy of "textured_shapes

2018-11-14 13:46:22 -0600 commented question Problem of creating a model with texture and using a ros camera

I changed the script because otherwise I can't precise which texture it should use. Yes it's a PNG that a generated usin

2018-11-14 13:44:47 -0600 commented question Problem of creating a model with texture and using a ros camera

textured_shapes(copy) folder is the copy of above one. Where I deleted the sphere and cylinder and juste change the png

2018-11-14 13:43:19 -0600 commented question Problem of creating a model with texture and using a ros camera

Here you can find the files : https://github.com/michou214/Rendering_problem APtag folder is a copy of "textured_shapes

2018-11-14 13:43:07 -0600 commented question Problem of creating a model with texture and using a ros camera

Here you can find the files : https://github.com/michou214/Rendering_problem APtag folder is a copy of "textured_shapes

2018-11-14 13:42:33 -0600 commented question Problem of creating a model with texture and using a ros camera

Here you can find the files : https://github.com/michou214/Rendering_problem APtag folder is a copy of "textured_shapes

2018-11-14 13:42:19 -0600 commented question Problem of creating a model with texture and using a ros camera

Here you can find the files : https://github.com/michou214/Rendering_problem APtag folder is a copy of "textured_shapes

2018-11-14 13:41:49 -0600 commented question Problem of creating a model with texture and using a ros camera

Here you can find the files : https://github.com/michou214/Rendering_problem APtag folder is a copy of "textured_shapes

2018-11-14 13:41:36 -0600 commented question Problem of creating a model with texture and using a ros camera

Here you can find the files : https://github.com/michou214/Rendering_problem APtag folder is a copy of "textured_shapes

2018-11-14 13:41:15 -0600 commented question Problem of creating a model with texture and using a ros camera

Here you can find the files : https://github.com/michou214/Rendering_problem APtag folder is a copy of "textured_shapes

2018-11-14 09:56:30 -0600 received badge  Popular Question (source)
2018-11-14 09:42:25 -0600 commented question Problem of creating a model with texture and using a ros camera

I edit my problem to give you more details.

2018-11-14 09:41:49 -0600 edited question Problem of creating a model with texture and using a ros camera

Problem of creating a model with texture and using a ros camera Hello everyone, I'm quite new in Gazebo and ROS but eve

2018-11-14 09:41:29 -0600 received badge  Editor (source)
2018-11-14 09:41:29 -0600 edited question Problem of creating a model with texture and using a ros camera

Problem of creating a model with texture and using a ros camera Hello everyone, I'm quite new in Gazebo and ROS but eve

2018-11-14 02:46:47 -0600 commented question Problem of creating a model with texture and using a ros camera

I'm using Gazebo 7 and ROS Kinetic. I'll try your suggestion this afternoon and keep you in touch. How did you try it ?

2018-11-13 16:15:26 -0600 asked a question Problem of creating a model with texture and using a ros camera

Problem of creating a model with texture and using a ros camera Hello everyone, I'm quite new in Gazebo and ROS but eve