Gazebo | Ignition | Community
Ask Your Question

Il_Voza's profile - activity

2014-12-04 05:58:43 -0500 received badge  Famous Question (source)
2014-08-14 00:57:43 -0500 received badge  Famous Question (source)
2014-08-14 00:57:43 -0500 received badge  Popular Question (source)
2014-08-14 00:57:43 -0500 received badge  Notable Question (source)
2014-07-22 18:22:06 -0500 received badge  Student (source)
2014-07-22 18:21:46 -0500 received badge  Famous Question (source)
2014-07-22 18:21:46 -0500 received badge  Notable Question (source)
2014-07-10 13:26:27 -0500 received badge  Famous Question (source)
2014-05-06 11:22:19 -0500 received badge  Popular Question (source)
2014-05-02 12:04:58 -0500 received badge  Notable Question (source)
2014-04-30 05:21:24 -0500 received badge  Notable Question (source)
2014-04-29 19:11:30 -0500 received badge  Popular Question (source)
2014-04-28 12:19:15 -0500 asked a question Error [Plugin.hh:138] Failed to load plugin libgazebo_ros_camera.so: libCameraPlugin.so: cannot open shared object file: No such file or directory

Hello guys, I have the following issue on gazebo 1.9 (ROS Hydro - Ubuntu 12.04): I have a package, for example pioneer3at, where in .sdf file some plugin, as libgazebo_ros_camera.so, are inserted. When I type roslaunch pioneer3at myfile.launch

it gives me this error

Msg Waiting for masterMsg Connected to gazebo master @ http://127.0.0.1:11345
Msg Publicized address: 172.20.242.19
Error [Plugin.hh:138] Failed to load plugin libgazebo_ros_camera.so: libCameraPlugin.so: cannot open shared object file: No such file or directory

I tried also to set env variable GAZEBO_PLUGIN_PATH correctly but however it doesn't work. However I noted that, in a tutorial of gazebo about RRBot Example, when I typed roslaunch command, it gave me the same error but with a several plugin:

Error [Plugin.hh:138] Failed to load plugin libgazebo_ros_control.so:libgazebo_ros_control.so: cannot open shared object file: No such file or directory

To resolve this last problem, I installed ros-hydro-gazebo-ros-control package. Now my question is: to resolve the problem with libgazebo_ros_camera.so:libCameraPlugin.so, I should install a missing package or what? This is really important for me... Excuse me and thanks to all

2014-04-28 12:02:52 -0500 asked a question roslaunch error [gazebo-1] process has died

Hello guys, I'm following this tutorial on gazebo 1.9 http://gazebosim.org/wiki/Tutorials/1.9/ROSMotorandSensorPlugins but when I type: roslaunch rrbotgazebo rrbotworld.launch

it gives me this error

Msg Connected to gazebo master @ http://127.0.0.1:11345
Msg Publicized address: 172.20.242.19
[INFO] [WallTime: 1398703874.946736] [0.207000] Spawn status: SpawnModel: Successfully spawned model
[urdf_spawner-3] process has finished cleanly
log file: /home/a2ur4/.ros/log/7e4dd822-cef3-11e3-85cd-001bb1f663f3/urdf_spawner-3*.log
Segmentation fault (core dumped)
[gazebo-1] process has died [pid 21117, exit code 139, cmd /opt/ros/hydro/lib/gazebo_ros/gzserver /home/a2ur4/catkin_ws/src/gazebo_ros_demos/rrbot_gazebo/worlds/rrbot.world __name:=gazebo __log:=/home/a2ur4/.ros/log/7e4dd822-cef3-11e3-85cd-001bb1f663f3/gazebo-1.log].
log file: /home/a2ur4/.ros/log/7e4dd822-cef3-11e3-85cd-001bb1f663f3/gazebo-1*.log
[gazebo_gui-2] process has finished cleanly
log file: /home/a2ur4/.ros/log/7e4dd822-cef3-11e3-85cd-001bb1f663f3/gazebo_gui-2*.log
all processes on machine have died, roslaunch will exit
shutting down processing monitor...
... shutting down processing monitor complete
done

How can I resolve? Thanks to all

2014-04-25 15:43:51 -0500 received badge  Popular Question (source)
2014-04-18 12:11:40 -0500 received badge  Editor (source)
2014-04-18 12:11:09 -0500 asked a question How to add rqt_robot_steering parameters

Hello guys, My environment simulation contains a Willow Garage and a pioneer3at. I see that by rqt_gui (precisely by rqt_robot_steering) I can manipulate parameters as linear velocity and angular velocity of pioneer. In fact the code of rqt_robot_steering.launch is:

<launch>

<node pkg="rqt_robot_steering" type="rqt_robot_steering" name="Pioneer3AT_rqt_teleop">
  <param name="default_topic" type="str" value="/Pioneer3AT/rqt/cmd_vel" />
  <param name="default_vx_max" type="double" value="0.8" />
  <param name="default_vx_min" type="double" value="-0.8" />
  <param name="default_vw_max" type="double" value="1.5" />
  <param name="default_vw_min" type="double" value="-1.5" />
</node>

</launch>

If I would to manipulate parameters as linear velocity of a single wheel, or apply joint effort or apply body wrench, implementing them on rqt_robot_steering.launch, how can I edit this file? Thnx

2014-04-17 11:30:00 -0500 asked a question Gazebo 1.9 slow rendering with collada (.dae) file

Hello guys, I have an issue: I made a 3D model by Sketchup, and I exported a collada file of size=25 MB (it is a 3D model of a Lab). When I make a my file .world where I put my file .dae, and I type "gazebo my_mesh.world" command, gazebo takes about 5 min to do to appear the model on simulation, and then the rendering is too slow. My pc is:

Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz

Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller

RAM 16 GB

I updated my graphic card driver following this tip: http://answers.gazebosim.org/question/2658/gui-rendring-is-very-slow/ , but nothing =(. How can I resolve? Thnx to all!