Gazebo | Ignition | Community
Ask Your Question

TinK's profile - activity

2019-04-20 07:33:52 -0600 received badge  Supporter (source)
2019-04-20 07:33:38 -0600 marked best answer Error in REST request for accessing api.ignition.org

Hi, I am trying to run an existing environment in Gazebo for my ROS project. Basically I need to do some robot navigation in a predefined environment. After installing all the dependencies and doing the setup of the workspace I try to roslaunch the environment. However, Gazebo opens up an empty environment. That is a problem since there ought to be a large floor with a couple of offices and some obstacles for the robot, as well as the robot itself. I checked the startup initialization and there seems to be a problem with accessing api.ignition.org, as shown in the picture below.

image description

I tried pinging the server but got no response and after googling it, I realized it was a large storage of models for gazebo, which got me to the conclusion that this error was responsible for an empty environment opening in Gazebo.

I am new to Gazebo and have only a slight experience with ROS so I apologize if I didn't use correct terms for explaining my problem. I wonder if someone else had a similar problem and if so, is there a way to fix this. I am using ROS melodic version 1.14.3 and Gazebo version 9.0.0

Thank you for your time and help.

2019-04-20 07:33:38 -0600 received badge  Scholar (source)
2019-04-13 09:49:42 -0600 received badge  Famous Question (source)
2019-04-12 23:38:21 -0600 received badge  Student (source)
2019-04-12 23:38:16 -0600 received badge  Notable Question (source)
2019-04-12 23:38:16 -0600 received badge  Popular Question (source)
2019-04-10 12:05:01 -0600 asked a question Error in REST request for accessing api.ignition.org

Error in REST request for accessing api.ignition.org Hi, I am trying to run an existing environment in Gazebo for my ROS

2019-04-10 12:05:00 -0600 asked a question Error in REST request for accessing api.ignition.org

Error in REST request for accessing api.ignition.org Hi, I am trying to run an existing environment in Gazebo for my ROS